Ford Powerstroke Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
im having a problem with my 01 when it sits overnight or for a long period of time. it starts fine but if i take right off with it i get like a mile down the road and it just quits like its getting no fuel. once it warms up its fine.....put a new fuel filter and cam sensor in it. (the one below the water pump cam or crank i forget?) still no difference. any one have any ideas?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
i was just reading some other posts could it be the icp sensor? what does the icp do?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
no it runs fine other than right before it stalls it misses and sounds like its falling apart, and sometimes white smoke when im trying to keep it running. hard to start back up after it stalls and usually runs fine after i get it running again.....its definatley not getting fuel when it stalls.
 

·
Registered
Joined
·
35 Posts
IPC= Injector pressure control. This has the potential of going bad intermittently (non coded problem) and will cause the injector's to shut down. The external operating temprature of the engine can mask this problem (can effect the sensor). Find out what the correct values are for the sensor resistance and check it w/ a multimeter. The IPC is pretty pricey at $350 dollars I think. And for heavens sake ... BUY A NEW ONE if you even need 1. Also, have your batteries load tested.
 
1 - 5 of 5 Posts
Top