Ford Powerstroke Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi everyone, I'm new to the group, just came across it while looking for some diagnostic advice with my 96 7.3. The truck is stock, 190k miles, 4x4 manual trans. The truck starting running rough with no power (like not on all cylinders) and my dad put in a new (but aftermarket) CPS and I found the ICP had oil in connector and cleaned it up and replaced sensor. Ran good for few months, and now the same thing. Currently the only code is P0344, which I have a new Ford one coming.
KOEO showed following codes: 1271 & 1277 (cyl 1&7 high to load side open), 1295 &1296 multiple faults bank 1 & bank 2, 1297 high sides shorted together.
Buzz test shows identical to KOEO. When this first started, the buzz test showed 1293 & 1295.
Contribution showed P0263 & P0269 ( cyl 1&3 contribution/balance fault).

Although the following codes aren't currently present, they have shown since this problem started: P1280 ICP circuit low, P1668 PCM-IDM diag communication error, P1661 output circuit signal low.
Def a short somewhere. Wiggle test finds nothing. Thinking IDM?
 

·
Registered
Joined
·
4,025 Posts
Have you visually inspected the valve cover connections?

The UVCH could be fried too. Remove the IDM and give it a shake and see if any water is in there.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I did pull the valve covers and visually checked all the plugs. Nothing looked bad or smelled burnt. I did NOT check for resistance though. I'll pull IDM today.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Just pulled the IDM and sounds more like a keg than a piece of electrical equipment! 🤨
Anyone have advice of best replacement?
 
1 - 4 of 4 Posts
Top