Ford Powerstroke Diesel Forum banner
61 - 68 of 68 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter · #62 · (Edited)
Alright, finally time for an update! Truck if finally back up and running like it should. Started out with two bad injectors and turned into a big project in the driveway! ARP studs installed with OEM head gaskets, rebuilt oil cooler, blue spring kit, turbo cleaned up, 4" Turbo back MBRP exhaust, Edge CST installed with EGT acc. and Fuel Pressure sensor (still not working, looking into that). First problem I had was with injectors, went with 155's with 30 nozzles, one was bad and giving me problems, second was IPR valve. After reassembly had the RLS problem and throwing codes for cylinder 1 contribution. After a mix up with the injector, finally got what I needed and installed. Also had a problem with something that screwed up the IPR valve screen bad! When it was pulled out the screen was dented in like something had hit it hard and caused a cackle when you took your foot out of it. Also had the heads milled, tanked, valve job and new seals installed. Once the truck was running right, I got to plug in my SCT SF3 and am currently running the performance can tune, and holy **** did it wake that motor up! Also sent the FICM to FICMrepair and had it upgraded and installed the Atlas 40, as far as I know there was no problem with the FICM I still have to call to make sure but he said he would contact me if it was bad from the start. Can't thank all the guys here enough that helped me work through this, now I have a new found love for my truck, but gotta watch my *** and not get a ticket!

:ford:

Forgot, also installed a BPD EGR cooler as well with a new EGR valve.
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #64 ·
You said after assembly had the rls problem, what's that? And what did you need to fix it?
It was still an injector, after it was replaced it cleared up.
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #66 ·
Sorry bout that, its a generic term we used on work orders for customers that couldn't quite tell us what was wrong except that it "Runs Like Sh!t" RLS.
 

·
Premium Member
Joined
·
1,407 Posts
Sorry bout that, its a generic term we used on work orders for customers that couldn't quite tell us what was wrong except that it "Runs Like Sh!t" RLS.
hahahaha, that's a new one to me. I was reading way to deep into that, I thought it was some like, RLS sensor or ford scanner system or something. I'll remember that one, thanks!
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #68 ·
Haha, thats funny, but easily done. I ask that a lot myself to of other members because I am not familiar with all the sensors and abbreviations of words used on the 6.0L. :D
 
61 - 68 of 68 Posts
Top