Ford Powerstroke Diesel Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Good morning. I have a 2011-12 Ford Ranger 3.0 liter I4 International powerstroke . Tanked up with bad fuel at some point. Truck was loosing power and had strange throttle pedal response. Swapped Fuel filter clogged black. Swapped filter, drained, removed cleaned out tank, fuel pump was filthy with dirt and water. Truck ran normal again but then started having a strange symptom. The throttle response is strange sometimes surging with steady throttle. Most noticeable symptom that has returned is when accelerating and shifting gears chop throttle push clutch down the throttle stays wide open for 1-2 seconds motor free revs to 4,000 - 5,000 rpm then drops to idle. This only happens when shifting under hard load. If idling in neutral I can blip the throttle and it goes up and down like normal. I had the injection system electronics tested. High pressure pump and all injectors are within normal range. I bought a new electronic fuel pedal swapped it did not cure the issue. I cleaned the MAF sensor which was visibly dirty did not sure the issue. As this truck had no emissions system at all factory no EGR, no Catalyst no DPF there is no issue to look at emissions wise. Anyone have any ideas on fixing this issue? Maybe injectors are bad even though the show good on test?
 

·
Registered
Joined
·
722 Posts
Assuming you got this truck from south America somewhere? or Australia maybe? I have only seen a 3.0 gas motor in the states. Heard of the 3.0 inline diesels but never seen one. Sorry i cant help much, but i hope someone does.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 · (Edited)
Assuming you got this truck from south America somewhere? or Australia maybe? I have only seen a 3.0 gas motor in the states. Heard of the 3.0 inline diesels but never seen one. Sorry i cant help much, but i hope someone does.
I am in Brasil. The engine is the MWM International Powerstroke. I figured out the problem. IP and Injectors are all good. The issue is the Engine speed rotation sensor which is mounted on the bell housing. The truck has a 5 speed manual. This sensor controls the injection. I ordered a new sensor should be here next week. Videos of truck and engine below


20 psi Boost and slow spool before ecu remap

Fast spool 25 psi after ecu reflash
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top