Ford Powerstroke Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Just bought an 01 F350 Powerstroke w/200k miles. While driving the other day the truck lost all power and started missing and the check engine light came on. I limped back to my shop and left it overnight. The next day, It wouldn't start at all. So I replaced the CPS and still would not start. I finally took it to a reputable shop and they took off the valve covers and found nothing wrong with the harnasses. After all of this trouble and several hundred dollars later, all it took was clearing the codes. The truck fired right up and ran fine. I am extremely uneasy about driving this truck now as I think that it is a major safety issue. My mechanic thinks that the ECM is bad. I was told that the previous owner installed an 80 hp chip in it. What should I do?? Replace the computer?? I NEED HELP. THANKS
 
J

·
Guest
Joined
·
0 Posts
First off.

Just clearing codes wont make a difference. There is something intermitant here. Please dont tell me Mr Reputible didn't write the codes down! Please dont say he just erased them!:eek:
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I appreciate the quick response. Will check with him tomorrow when I pay the bill and hopefully he wrote them down. He told me that there were several codes and basically nothing was conclusive. He is sure that it is the aftermarket chip. If this problem persists, Ill know that it wasn't the cam sensor.
 
J

·
Guest
Joined
·
0 Posts
There are so many different codes

that are possible in these trucks. You will get your azz chewed at my dealership if you EVER erase codes without writing them down.
 

·
The Fat Mod
Joined
·
12,508 Posts
The only way a 80hp chip should do anything is if the connection was bad on the chip and the chip was still in place. If there is no longer a chip, all of the chip effects should be gone. Chips are there if they're there, and gone if they are gon, now what I mean. No lasting anything. A programer is different, but not the chip. If the chip was still in there and gotten loose, it could have done it, but it sounds like your "guy" don't know a whole lot about the PSD
 
1 - 6 of 6 Posts
Top