Ford Powerstroke Diesel Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
Hello all,
I recently purchased a 91 Ford 7.3 idi....I bought it for 1100.00 and it ran but stuttered...had a local diesel repair shop look it over....they rebuilt the injector pump (or said they did) and it ran fine for about a week .. I bought a Chiltons and went to work...found a loose connection on the sensor which mounts to the top of the fuel pump....Also found several shorted wires which were fixed. At the same time I replaced the fuel filter and changed the oil (synthetic). I decided to drive to Texas and back and it gave the same hard start problem. I made it back though and as soon as I pulled into my driveway it quit.

I found the fuel leak. The fuel pick up pump hose had about 10 leaks in it. I replaced it and also replaced the o-rings on the t's over the injector and the glow pugs. Started, ran and shifted alot better. However, I also noticed that during the two months I have driven the truck the oil pressure has fallen from half normal to before the N on normal. I checked the oil and it was black and thin (smelled like diesel). Figured this was due to the fuel problem. No coolent in oil or oil in coolant. No dripping oil or coolant leaks. Residual leaks where the oil cooler mounts to the block (towards front of truck), where tranny mounts and where the injectors meet the head (about 5 have residual leaks).

I am scared to drive it for fear of major break down. Does anyone have any idea on the low oil pressure indication?

additional things i noticed which may or may not be relevant are
1) felt a grinding from under the drivers floor area but the grinding has stopped recently.
2) before it quit the last time the oil pressure gauge lowered a hair and the engine temp gauge flunctuated back and forth from just before half and half (never did rise though).
3) I started the truck several times let it build compression, killed it and listened for a leak....I hear a very slow leak sounds like near the air breather hole (cant find it though) as far as I know it may be a bleed off valve...first diesel.

The "mechanic" told me that he found no blow by.....but this is the same guy who did not check the $2.00 fuel hose or replace the dryrotted fuel hose to at the fuel lines...or the o-rings for that matter. The truck starts first turn of the key and runs fine...but I am not chancing the low oil pressure indication.

Any help would be greatly appreciated. Thx.
 

·
Registered
Joined
·
33 Posts
Same problem???

I have 1992 F250. In general seems to start OK and once started runs great (except I get bad mile per gallon (12 highway)), but I noticed that the oil pressure gauge is different every time. Some time it is near the "O" and some times the "R" in normal. If I change the oil it will be closer to the "M".
Thanks for the help
 
1 - 2 of 2 Posts
Top