Ford Powerstroke Diesel Forum banner

1 - 6 of 6 Posts

·
Vendor
Joined
·
12,831 Posts
Discussion Starter #1
Truck was smoking bad a while ago. One day it got really bad. Like city truck fogging for mosquitoes bad. Thought my turbo seal went bad. Good excuse to use to get my GTP38R with WWgen2 wheel :D. Got it installed with new International bellowed up-pipes and RiffRaff billet intake plenums. WOW, what a PITA trying to get the up pipe collector to the turbo. After 6 he's or trying by the directions I had in all together in an hour by doing it kinda backwards.

Truck still smokes really bad. So I pulled the injectors to check the O-rings, all good. Bought a compression tester. Had to modify it to hook up the quick connect. Tig welded a 1/8" x 4" pipe nipple to extend it. I was a bit nervous thinking I was going to have at least 1 dropped cylinder since the turbo wasn't the issue. And my injectors only have 7k miles.

My numbers were very strange. Of course this is my first time
checking compression on a 7.3. So....

380,580,560,700 driver
420,440,440,600 pass

Huh :confused:

Lesson learned. You need to put all injectors back in and and then turn the engine over with GP's out to get all the oil out of the cylinders. Not one at a time like I did. Doh. :what: what happens if you don't, while cranking the engine over you will refill the oil galley, of course with the injectors out, you end up draining the pumped oil black into the cylinders. Since the oil drains to the back cylinder after a compression stroke that made the compression numbers higher in the back.
So..I reinstalled all the injectors turned it over for a bit and blew the oil out and numbers came out as follows.

380,420,420,440 driver
420,420,440,440 pass

Very happy about that. :D leak down check was also good.

Well. Talked to Ryan after agreeing on troubleshooting and I just sent the injectors back to FullForce for complete testing. Just to be sure I sent them all back. CCT was only giving me #3 and #8 but they were phantom codes since they didn't repeat.

That's where I currently sit.

Sent from AutoGuide.com Free App
 

·
Vendor
Joined
·
12,831 Posts
Discussion Starter #2
Update.

Ryan called me back, glad he found something so I wouldn't be chasing my tail. Found one of the injectors got a piece of debris stuck and wedged open the high pressure oil end. Can't wait to get them back in and see how big a difference it is going from a factory e99 setup to a 38R with the GEN2 dieselsite WW.

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
218 Posts
hmm now in starting to think my truck smokes a little because the last owner never changed the damn oil in it so maybe i have some debris in my oil side
 

·
Vendor
Joined
·
12,831 Posts
Discussion Starter #6
Got everything together and runs great. Gonna baby it for a bit though to get all the air out of the system.

Can't wait to try out a few WOT runs with the new 38R turbo w/ WW2. I've been running an e99 stock system long enough. :D

Soon enough will be the swamps IDM and stealth 1.1

Sent from AutoGuide.com Free App
 
1 - 6 of 6 Posts
Top