Ford Powerstroke Diesel Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter #1
i have a 2000 f250 with 185k miles, recently on a trip from florida to pa i was driving and it all of a sudden started acting like it was running out of fuel, but i still had almost a full tank, when i stopped it just sat there and loped. when i tried to hit the accelerator and move a little bit, it had no power at all, after about 5 minutes of sitting there and loping and me scratching my head it started running fine again like nothing was wrong? i had just started running diesel kleen thru it and i thought that was the problem, so i stopped and have run a whole tank of fuel thru and yet again today it did the same thing to me? some help on what could be going on would be much appreciated
 

·
Registered
Joined
·
50 Posts
Discussion Starter #4
what would be wrong with it? is there a short or an open somewhere? or is it just going bad? and how much of your money would you put on a new one?
 

·
Registered
Joined
·
50 Posts
Discussion Starter #5
sorry i looked at the link after i posted that last reply, but the does sound exactly like my problem, thank you for the help
 

·
Registered
Joined
·
8 Posts
Symptoms of your truck describes exactly issues I have with my truck. What I have done so far: First I checked for codes, no issue there, no codes. Replaced CPS part from NAPA, symptoms still shows. Look under drivers side valve cover and looks like the previous owner already put the quarter(Coin) fix on the wiring harness. I didn't look under the passenger side Im assuming the quarter fix already apply on that side. Pull the ICP, very clean and when I ran the truck with the ICP pulled, symptoms still shows. Repaired the IPR with the repair kit and the problem still exist. PULLING HAIRS RIGHT NOW.... any ideas where should I go from here? I really appreciate it.
 

·
Registered
Joined
·
8 Posts
I forgot to mentioned that when I was repairing my IPR which I have to drain out the HPOP reservoir it only contain half a quart. Then I look further in the engine bay and notice oil accumulated in the middle and the end of the block. I had tried to trace it thinking it was coming from the IPR(original IPR was still in) but it looks like it was coming from the passenger side of the block. It was wet starting from the valve cover streaming down toward the V area. I think this was a mistake in my part and I completely ignore it, I should fix and trace this leak first, it probably coming from the high pressure oil line. What you guys think?
 

·
Registered
Joined
·
50 Posts
Discussion Starter #9
Ok so when my truck starts acting up, shaking, no power, lost cylinders, how do i get it to run like it should? Or do i just let it sit and wait?
 

·
Banned
Joined
·
4,240 Posts
What do you mean by coin "quarter" trick?
It's refered to as the ".50 Cent Mod" because you take 2 quarters and grind off about 1/4 of the end and push it into the UVCH and it keeps the harness in place so it won't slip out. Make sure that when you pull the UVCH out you check the pins for any signs of burnt pins.
 

·
Real Men of Genius
Joined
·
5,309 Posts
saving this thread, might come in handy one day. Thanks ToMang!
 

·
Registered
Joined
·
50 Posts
Discussion Starter #14
Anybody who has done the 50 cent mod, do you have any pics or know where i can find any? I would like to see it before i try it
 

·
Registered
Joined
·
50 Posts
Discussion Starter #16
Ok so that looks pretty simple, but what is an IDM? Seen people having problems with it also and how will i test this?
 

·
Registered
Joined
·
8 Posts
Sorry guys I have being busy laying stone tiles on my kitchen floor, Im using my Exp getting supplies and Im missing my Truck very much. As soon as I get to the truck I will update what I can find.
 

·
Registered
Joined
·
50 Posts
Discussion Starter #18
Got my problem fixed, but I broke the piece that holds the connector together so now how do I go about getting a new one of those?
 
1 - 18 of 18 Posts
Top