Ford Powerstroke Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have recently purchased a F250 7.3 for pulling my camper. My camper weight is 10,000. Took it out for the first time this weekend and had some major issues. It pulled great until about an hour and a half into the pull. The first hour it pulled great up steep inclines. The last thirty minutes, while pulling the camper into the mountains (uphill) the truck lost most of it's power. At times I thought it was a fuel problem and at other times it felt like it wouldn't shift gears correctly. The check engine light came on. Two codes: P0340 Camshaft position sensor A circuit (bank 1 or single sensor) and P1211 Injector Control Pressure higher/lower than desired. I made it to the campsite. Let the truck cool off and ran great. While there I changed the camshaft sensor, air filter (which was clogged) and gas filter. On the way home the same problem. After the truck warmed up good...loss of power. I dropped my camper and still ran bad. It appears that the problem only surfaces when the truck is hot (all temp gauges are perfect) and when it is pulling a heavy load.

Side note a day before the trip I ran out of fuel, trying to determine mpg...the light never came one and showed fuel.

I have some thoughts but need some other viewpoints. Thanks in advance.
 

·
Registered
Joined
·
8,568 Posts
Check your icp for oil in the connector. If you find oil replace it with a ford only part. Next thing would be ipr. There is no test for them. But it'd right on top of the motor and subject to quite a bit of heat. That 1211 code made me think of those.

As for the fuel running out. You most likely have the pickup foot broke off your sending unit. Read this. http://www.guzzle7pt3.com/hutch.php
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I thought the same thing about the foot falling off. Some other things I thought: the two filters on the sending unit inside the tank could be clogged, maybe an exhaust problem withe the c. converter?
 

·
Registered
Joined
·
8,568 Posts
Hutch mod will fix the foot and the filters. I don't think that the converter is the problem due to the fact it's just after it gets hot. Not all the time. A good way to tell what is going on is to monitor it. You could get the torque app for android phones and the blue tooth dongle ($30) autoengenity for $400. Or the scan gauge 2 $200. The scan gauge can't pull codes though.
 
1 - 4 of 4 Posts
Top