Ford Powerstroke Diesel Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
212 Posts
Discussion Starter #1 (Edited)
I'm having engine problems recently that I'm thinking are injector issues. I periodically have a loss of power when I get into the throttle ... I first noticed it when accelerating out of a toll booth and also when climbing bridges. I don't have enough power to accelerate. EGTs will climb high, turbo boost stays low, truck loses speed, and the engine begins to shudder. There is no check engine light. I usually don't notice this when cruising on level ground or when accelerating casually.

The engine has 165,000 miles on the original injectors.

Before I drop the few grand on new injectors ... can anyone propose any other possibilities?
 

·
WNY Biodiesel Co-op
Joined
·
915 Posts
i'm having the same problems. I know i need to change my injector o rings and possibly #1 and 8 injector. I lost 2 gals of oil on a recent trip as the motor started to lose power. It didn't leak it , it must have burned it. The only place I could lose that much oil would be past the injector o rings. Get a scan done with an Auto Enginuity and do an injector contribution test.
 

·
Registered
Joined
·
200 Posts
by chance have you checked your turbo shaft play? or do you hear a hissing when the power loss occurs? the compressor wheel may be hitting the housing and sticking under hard acceleration. or if there is a hissing the ebpv may be sticking closed, thus dropping boost, power,blocking the exhaust causing high egts....... just some options
 
1 - 3 of 3 Posts
Top