Ford Powerstroke Diesel Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Guys and Gals,
Have an 08 F-350 KR that loses power and smokes under heavy acceleration. The funny thing is it only does it when I am cruising at least 65mph and the engine is warmed up. I have to let off of the gas (or diesel pedal) and then accelerate slowly to get any kind of pickup. Won't do it right after I start it up and get on the highway. The dealer has had it for over 2 weeks now and they can't seem to find out what is wrong with it. Supposedly they have the engineers from Ford involved, but they could be blowing smoke also. Ford said they haven't run across this problem before (what ever happened to being able to troubleshoot a problem?) but I was wondering if anybody has had or heard of someone who has had a similar problem with the new engine.

Thanks for any help.
 

·
Registered
Joined
·
781 Posts
dont know much about the new ford but when i get a d-max in with strang stuff like this most of the time it is that the customer had put high solfer fuel in the truck and they dont like that at all can you drive by the pump you filled up at last and see if pump has a sticker that says ultr low sol. or if it said low sol. not for use on 07 and newer trucks?
 

·
Registered
Joined
·
781 Posts
may just be a bad batch of fuel. but how much fuel do you have in you tank? and have you filled up at the same place before? have they pulled a samplie of the fuel?
 

·
Registered
Joined
·
781 Posts
most times with bad fuel on an older truck it will miss till it gets warm then run fine but could work opposet.
 

·
Premium Member
Joined
·
1,489 Posts
I have 2 '08s and they act completely different. The 450 has a sparkling clean tail pipe, and has no smoke at all.
My 350 is a different animal. It smokes every time I accelerate (even when I try to go easy at it). It's tail pipe is black as coal. Every once in a while I will try to accelerate with it, and it will just shutter and blow white smoke, and not do anything. If I try again with less throttle, it will eventually accelerate (this is while you are cruising down the highway). I don't know if that might tell you anything. I don't want to hijack your post either. But, does anyone know why my 450 might be able to boost to 36-37lbs (stock) and my 350 never break 30 (stock)?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #11
Thats weird because I can always get around 38 lbs of boost when I get into it. But the truck doesn't want to go anywhere even with that much boost. It's amazing that these new engines can have so many different quarks to them on different trucks.
 

·
Registered
Joined
·
2 Posts
same problem different smoke!

08 f450 king ranch crew cab dually 4x4, have blown 2 radiators, have tail pipes that look like i could cook a barbeque in them. no power on acceleration and fuel mileage that is around 8. the truck has been at the dealer more than on the road and they can't duplicate the problem even though the mechanic states "yea i can see there is a problem but there aren't any codes"!!!!! i had another mechanic at another dealership state he saw rust on my turbo vanes and they were sticking. and ford won't help!
 
1 - 12 of 12 Posts
Top