Ford Powerstroke Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
Hey guys i have a 04 6.0. Recently i have been noticing that at a stop light my truck will idle really rough and lope pretty bad. When I'm driving highway speeds it goes away ad drives fine though. The truck starts up rough but it always has in the mornings. I can't figure it out... I recently changed the oil and both fuel filters and it went away for a day or two but now its back. The truck is SCT tuned, straight piped and has an AFE intake But I'm sure that doesn't have much to do with it. If someone could help e out that would be perfect.
-Rob
 

·
Registered
Joined
·
4,914 Posts
Need to see if you have some stored codes. Check ficm, fuel pressure, load test batteries.

Sent from my phone that somebody didn't help me get.
 

·
Registered
Joined
·
55 Posts
Discussion Starter #3
I brought my truck down to Alligator Diesel in CDA idaho and they scanned the truck and couldn't find anything. Could it be an injector mis firing and it didn't throw a code?
 

·
Registered
Joined
·
4,914 Posts
I think that is possible.....you should remove the tune, see if it clears up.

Sent from my phone that somebody didn't help me get.
 

·
Registered
Joined
·
55 Posts
Discussion Starter #5
sorry that took so long to respond... I de-tuned it this morning but it did the same thing. Went out to the local walmart and bought some diesel additive and it runs a little smoother now which gives me the impression that the injectors could be clogged up or loosing power. Any advise?
 

·
Registered
Joined
·
4,914 Posts
Charge your batteries, load test them, google ficm check procedure.

Sent from my phone that somebody didn't help me get.
 
1 - 6 of 6 Posts
Top