Ford Powerstroke Diesel Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
225 Posts
Discussion Starter #1
do i have oil dripping down my bell housing and onto my front drive shaft, no idea where it comming from? anyone had this problem before? maybe a vlave cover gasket?
 

·
Registered
Joined
·
225 Posts
Discussion Starter #3
i will give alittle more detail, looks to be comming from on the head somewhere, freeze plug? harness? valve cover? seems to be running down from up in that area and dripping down the bellhousing onto the front drive shaft where the boot is. I do ALOT of highway driving and the truck only has 62k on it, had one injector replaced on it. (broke a gasket? seal? at dealership?) also it seems to smell on long trips say over 2+ hours on the highway, seping alittle maybe hitting an up pipe? its not bad at all but im just a perfectionist. think i should worry about it or just takel it when i do studs and everything... im assuming in the next 10k
 

·
Registered
Joined
·
225 Posts
Discussion Starter #5
im not sure what side it was on. was down prior to me buying the truck, wondering if other people have had similar issues
 

·
Registered
Joined
·
225 Posts
Discussion Starter #7
i took a picture tracked it too up top of the engine but still dont know what its comming from....
 

·
Registered
Joined
·
225 Posts
Discussion Starter #8
picture

here is what i could take a picture of anyone got ideas?
 

Attachments

·
Registered
Joined
·
225 Posts
Discussion Starter #9
any ideas?
 

·
Registered
Joined
·
225 Posts
Discussion Starter #10
has anyone seen this issue? dripping down the back of the motor? maybe coming from under the turbo? how hard is it to pull the turbos? cab on possible? all input needed!
 

·
Registered
Joined
·
513 Posts
Turbo oil Line (return or feed) maybe?? Take off some shields and start digging deeper...
 

·
Registered
Joined
·
225 Posts
Discussion Starter #12
if i take the sheilds off can you see the feed lines??? never had them off before.
 

·
Registered
Joined
·
88 Posts
I has the same issue but never had the time for looking for
 
1 - 13 of 13 Posts
Top