Ford Powerstroke Diesel Forum banner

1 - 4 of 4 Posts

·
Powered By Dinosaur poop
Joined
·
26 Posts
Discussion Starter #1
Ok so installed some HID headlights on my 02 F250 as I live in Alaska and suffer from poor night vision. After installing the headlights I noticed when I am driving and turn the lights on my cluster goes into reset mode where all the needles sweep then it returns to normal. I have checked all connections to ensure there are no shorts (its a plug and play system).. just trying to figure out if maybe a resister is needed or something.


Thanks
 

·
Registered
Joined
·
502 Posts
HID's and these year trucks dont get along... Look on ebay for some Ferrite beads. Do you have a tuner on the truck?
 

·
Premium Member
Joined
·
8,483 Posts
Nothing to worry about,, perfectly normal for our system to react that way to the RF spike generated by the HIDs ballast. Just drive ;)
 

·
Powered By Dinosaur poop
Joined
·
26 Posts
Discussion Starter #4
Ok was concerned it might be a big issue. I do have a tuner on the truck as well as some other mods ill list below:

:Superchips Flashpaq
:AirAid intake
:4'' turbo back magnaflow exhaust
:4'' FabTech lift with fabtech dual stabilizer
: 17'' rims with 36s
:07 front end conversion
:Airbags in the rear

EGT's and Boost are on par but I have run into a issue with the truck hitting limp mode with the performance tune (over boost) still researching how to combat this I know with my old turbo gas cars I used to race we would run a Map Clamp to fool the PCM into not seeing the extra boost.

I bought the truck in May while deployed to Afghanistan she had 198K on the ticker and when I came home for R&R took the truck from Seattle to So Cal and it did great on fuel I was averaging 550-600 a tank running at 75mph.
 
1 - 4 of 4 Posts
Top