Ford Powerstroke Diesel Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
2004 F250 6.0L – 180,000 miles
About ten months ago I went to the store and my truck was running just fine, but when I was on my way back home it suddenly had no power at all, couldn’t even go up a very small hill and was billowing white smoke. I though I had lost an injector. There were no codes. I shut the truck off and checked a few things but didn’t find anything obvious. I then restarted the truck and it ran great, nice and smooth, lots of power and no smoke! This has never happened again, however, for some time now my truck has had an intermittent rough idle. Most of the time it runs just fine, however sometimes when I get to a red light or off the highway the truck will have a rough idle. 99% of the time I can get it to go away if I can give it a hard acceleration for a few seconds down the road, and then it will be running just fine again. There is no smoke or engine codes, no oil leaks and no coolant leaks.
The only other incident that has happened was about two weeks ago. I got off the highway and the truck was running rough. I couldn’t open it up because I had to sit through a series of red lights and lots of traffic. As I went the idle got rougher until the truck would almost not move and was shuddering badly. It would build up speed very slowly even with the pedal to the floor. Finally I was able to get it up to 45 mph with the rough idle and no smoke. The engine light came on with codes for “injector circuit low” on 6 cylinders. After I got onto the highway I got the truck up to 65 mph and still no smoke. After a few miles the engine suddenly got smooth and the truck had no problem accelerating. It was like nothing ever happened. When I got home I cleared the codes and they have not come back and the truck continues to run just fine except for the intermittent rough idle which had already been present. I’m thinking a sticking ERG or a FICM issue? Just strange that it comes and goes like someone turning a light switch on and off. Anyone have suggestions or has seen this happen before?
 
1 - 2 of 2 Posts
Top