Ford Powerstroke Diesel Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi everyone, this is my first post.. I bought my truck about 2 months ago, i love the body style of the fords and found an all black lariat centennial edition.. i bought it knowing about the problem child 6.0L's

anyways, i took it to a local shop and they ran some tests and told me injector 3 was dead.. i had it replaced and the truck ran good for about a day, then it started missing again. I took it back to the shop and they said the ICP sensor, the turbo, and the glow plug relay needed replace. They claimed the turbo wasn't boosting, however my boost gauge says it is lol.. needless to say i have taken it back. A couple days later my truck threw a code, it was the ICP sensor code so i had it replaced at the dealership. I am still having problems lol

here are the symptoms:
-rough idle and grey/white smoke on cold start ups
-doesnt fire right up when starting like other 6.0Ls (rpm's dont shoot right up)
-missing at low rpms under load (can tell especially in overdrive when it shudders)
-horrible boost lag until 1800-2000 rpms

the biggest thing i am concerned about it the missing under partial throttle at low rpms, when the truck is over about 2200 rpms the missing isnt nearly at noticeable. full throttle you cannot tell its missing at all.

i am thinking of replacing all injectors, i am tired of this lol

thanks, dylan
 

·
Registered
Joined
·
1,039 Posts
Dylan, I had some similar issues a while back. My ICP sensor started going out, and I lost an injector. It exibited some of the same symptoms you are having with the rough idle, It sounds like you may still have a bad injector possibly. So they changed the injector before replacing the ICP sensor then? If so it may have possibly taken out the same injector. Does the truck seem to be relatively low on power? What year is your truck BTW? Best of luck with your problem, and welcome to powerstroke.org! There are alot of knowledgeable, good guys on here!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
it is a 2003 c/c centennial edition..

thanks for the reply, i was thinking the same thing
 
1 - 3 of 3 Posts
Top