Ford Powerstroke Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
I just took my truck to a shop and had them put the machine to it to determine what my problem was. I think I have injector issues since when cold it runs awful until warmed up. This is what the guy said

1. intake air temp sensor showing -40
2. fuel pump relay malfunction

codes that were shown
p0113
p0231
p0470
p1247

The intake air temp is unplugged and no longer there, duh, I threw it away with the old airbox

besides that he said all the injectors were flowing within specs and he didnt think there were any injector issues at all.

Knowing this, would it be safe to assume that the o rings may be bad on 1 or more injectors causing the rough idle, slow to no performance at all when cold?

I know I need a compressor wheel since it is chewed rather badly and plan on doing it at the same time as the injector o rings if determined I need to replace them.

The truck idles fine and runs as well as it should considering the compressor wheel is in the shape it is in.

Where should I start??

is everyone in agreement that if the injectors are flowing with in specs that when it is cold there is a leakdown on the injectors causing white smoke at startup? Glow plugs have been changed in the last 3 years and it is WARM outside


Please help me!!
 

·
Registered
Joined
·
25 Posts
Discussion Starter #2
Im sure someone out there has the answer! please help me!

I need to get this truck perfect so that I can sell my Lexus!
 

·
Registered
Joined
·
25 Posts
Discussion Starter #4
1 - 4 of 4 Posts
Top