Ford Powerstroke Diesel Forum banner
81 - 100 of 135 Posts

· Premium Member
Joined
·
1,679 Posts
If the relay was damaged it would cause running issues at all rpm's not just idle. If damaged it would be a consistent issue no matter what rpm the motor is at. Possibly worse at higher rpm as the current draw would be higher on the contacts in the relay due to more current going to the FICM (more injector on/off pulses at higher rpm - this is also ignoring the back emf of the coils when they shut off which will increase with rpm).

IMHO

Sent from my SM-G973W using Tapatalk
 
  • Like
Reactions: jokester00

· Compression Ignition Addict
Joined
·
12,071 Posts
I've seen a lot of relays like that get cracked from people using pliers to pull them out. They get squeezed and can damage the internals.
Only way I could figure a cause for it, but I wouldn't think @jokester00 would be one of those people!!!!! :oops:
 

· Premium Member
Joined
·
1,679 Posts
  • Like
Reactions: jokester00

· Premium Member
Joined
·
5,156 Posts
Discussion Starter · #85 ·
Yeah, I've never used pliers on the FICM relay...unless you count my manly beefy hands with the grip of death 🤣

-jokester
 

· Premium Member
Joined
·
4,809 Posts
Ah, the manly hands cause again.

Just for giggles: Did this long ago, two versions of Ford supplied FICM relays. Maybe more now.


Rectangle Font Material property Ac adapter Operational amplifier


Wood Rectangle Brick Line Wall


Building Wood Orange Brickwork Brick


Circuit component Audio equipment Gas Electronic component Cable


A small piece of tape or thick paper between the contacts makes the relay a non-start theft deterrent. Or snipping the small wire to the coil. But the paper makes it so the relay can be used again in an emergency.


I think this is the one I got, and so far seems to work well at a lower price than Ford.


Product Font Rectangle Material property Parallel
 

· Premium Member
Joined
·
5,156 Posts
Discussion Starter · #87 ·
Well, just a little update for those of you who followed this thread. It's been just over 6 weeks without an issue running the new tune (not the tune I was having issues with). At this point, i'm going to assume it was the tune causing the weird erratic idle issue, but unfortunately for you guys, i'm not going to retune it just to confirm :D I like confirmation, but i'll live without it this time LOL.

So, to recap: i'm pretty sure I had 2 issues going on throughout this whole thread...

1. I had a #8 injector that would randomly misfire when truck was hot (up to temp) - that was fixed and life was good.
2. The new tune (that ran great when it wasn't randomly idling like a cammed big block) was causing some sort of random erratic issue at idle - hot and cold.

Thanks to everyone who helped me out. Fingers crossed it stays this way :D

-jokester
 

· Premium Member
Joined
·
5,156 Posts
Discussion Starter · #88 ·
Well, after 4 months of running fine, my luck ran out today 😁

Truck started doing the same erratic idle like a cammed big block again today just as we dropped the trailer back off in storage after our trip. IPR was bouncing between 35-40% but ICPv was only reading 0.9v (I think ICP was ~620-650psi, but not sure). The good news is - it never happened on our trip, so that's my silver lining 🤣

This time, the IPR is getting R&R'd. I'm not 100% convinced that this is the issue, but I told myself this is the path I would take next if it happened again, and I even bought one before we left just in case I needed to swap it out on the road.

I'm just glad it didn't rear it's ugly head while we were on our trip! Stay tuned for another chapter of, "Jokester has to work on his truck again" 🤣

-jokester
 

· Premium Member
Joined
·
5,156 Posts
Discussion Starter · #90 ·
You going for the IPR valve now?

Looked like a fantastic trip. Those pictures were amazing.
Yup...finally convinced it's the IPR.

The trip was awesome. I'd load up and do it all again next month of we could! We had so much fun!

-jokester
 
  • Like
Reactions: bismic

· Premium Member
Joined
·
5,156 Posts
Discussion Starter · #91 · (Edited)
Swapped out the IPR this morning. Nothing abnormal seen on the old one, but didn't expect to see anything either. No way to tell if it's the original from when the truck was manufactured, as I bought the vehicle used, but it's never been removed by me the whole 65K miles i've had the truck. Can you tell if it's OEM by the these numbers or is there some identifying marking on it?

It did take some coaxing. I remembered it was tight when I pulled my turbo and tried to remove it then but was unsuccessful, so I told my dad that this might end up being fun. An 18 inch 1/2" ratchet, a 2' cheater bar, and some bloody knuckles later, we convinced it to break free 🤣

Anywho...fingers crossed!

@Hydro Send me your address in a PM and I'll send this one to you for FA if you still want to look at it.

-jokester

Finger Material property Nail Font Gas


Hand Finger Gas Bottle cap Thumb


Tool Finger Wood Gas Auto part
 

· Registered
Joined
·
471 Posts
Swapped out the IPR this morning. Nothing abnormal seen on the old one, but didn't expect to see anything either. No way to tell if it's the original from when the truck was manufactured, as I bought the vehicle used, but it's never been removed by me the whole 65K miles i've had the truck. Can you tell if it's OEM by the these numbers or is there some identifying marking on it?

It did take some coaxing. I remembered it was tight when I pulled my turbo and tried to remove it then but was unsuccessful, so I told my dad that this might end up being fun. An 18 inch 1/2" ratchet, a 2' cheater bar, and some bloody knuckles later, we convinced it to break free 🤣

Anywho...fingers crossed!

@Hydro Send me your address in a PM and I'll send this one to you for FA if you still want to look at it.

-jokester

View attachment 786959

View attachment 786957

View attachment 786958
Did that end up being your issue? I've been fighting that for over a year, maybe even 2.....I told the shop I go to to replace it but I'm not 100% confident they did. I have a reputation for being a hypochondriac.
 

· Premium Member
Joined
·
5,156 Posts
Discussion Starter · #93 ·
Did that end up being your issue? I've been fighting that for over a year, maybe even 2.....I told the shop I go to to replace it but I'm not 100% confident they did. I have a reputation for being a hypochondriac.
Jury's still out at this point. Give it 6 months and I'll report back 😁

-jokester
 
  • Like
Reactions: Hydro and bismic

· Premium Member
Joined
·
10,224 Posts
@Tathag Your truck running like this one ?

E450TN posted this vid showing how his truck was running -- worked out the be the IPR valve
Vid Here
Thread Here
 
  • Like
Reactions: Fonger

· Registered
Joined
·
471 Posts
@Tathag Your truck running like this one ?

E450TN posted this vid showing how his truck was running -- worked out the be the IPR valve
Vid Here
Thread Here
Not like that, but wow it makes me feel better about my issue. My truck starts great and runs great. It's is only when truck is all warmed up and when I get off a freeway and sit at stop lights. The idle will go from steady, to floating up and down between 590 and about 700rpm while icp voltage and psi fluctuate with it. IPR then sits at 25-26%. Then I go a few blocks and it's back to 22% and idle settles at 635-645. You and Bismic actually tried helping me out when I first posted about it. All this time and I still haven't found it.
 

· Premium Member
Joined
·
5,156 Posts
Discussion Starter · #100 ·
@jokester00 Im not sure if your issue is resolved. Is your truck deleted? If not, and your issue is still happening, have a look at your EGRDC% and see what it's at when your truck acts up.
I'm not sure if my issue is resolved yet either :D Last time it went 4 months without acting up. I swapped out the IPR on August 25th, so in 5 more months, i'll let you know :D

-jokester
 
81 - 100 of 135 Posts
Top