Ford Powerstroke Diesel Forum banner
1 - 17 of 135 Posts

Registered
Joined
471 Posts
Swapped out the IPR this morning. Nothing abnormal seen on the old one, but didn't expect to see anything either. No way to tell if it's the original from when the truck was manufactured, as I bought the vehicle used, but it's never been removed by me the whole 65K miles i've had the truck. Can you tell if it's OEM by the these numbers or is there some identifying marking on it?

It did take some coaxing. I remembered it was tight when I pulled my turbo and tried to remove it then but was unsuccessful, so I told my dad that this might end up being fun. An 18 inch 1/2" ratchet, a 2' cheater bar, and some bloody knuckles later, we convinced it to break free 馃ぃ

Anywho...fingers crossed!

@Hydro Send me your address in a PM and I'll send this one to you for FA if you still want to look at it.

-jokester

View attachment 786959

View attachment 786957

View attachment 786958
Did that end up being your issue? I've been fighting that for over a year, maybe even 2.....I told the shop I go to to replace it but I'm not 100% confident they did. I have a reputation for being a hypochondriac.
 

Registered
Joined
471 Posts
@Tathag Your truck running like this one ?

E450TN posted this vid showing how his truck was running -- worked out the be the IPR valve
Vid Here
Thread Here
Not like that, but wow it makes me feel better about my issue. My truck starts great and runs great. It's is only when truck is all warmed up and when I get off a freeway and sit at stop lights. The idle will go from steady, to floating up and down between 590 and about 700rpm while icp voltage and psi fluctuate with it. IPR then sits at 25-26%. Then I go a few blocks and it's back to 22% and idle settles at 635-645. You and Bismic actually tried helping me out when I first posted about it. All this time and I still haven't found it.
 

Registered
Joined
471 Posts
Well, it didn't take 4 months this time 馃ぃ

Hey @Tathag - no, the IPR did NOT fix my issue.

Today I was driving with steady throttle and the truck revved up like I pressed the skinny pedal. Hmmm...that was odd. Well, later on tonight, it lunged again with my foot nowhere near the skinny pedal, and on the way home tonight. The surging or lumging usually preceeds the erratic idle thing, so I knew it was just a matter of time. Tonight on the eay home from the kiddo's soccer game, it started with the erratic idle thing.

Well crap...time to start fishing for answers again. Gonna check out the ICP pigtail connections tomorrow (changed it out ~2 years ago). Might even change it out because I have one here at the house.

GRRRR...I hate intermittent problems!

@bismic @Hydro @TooManyToys @FordDoctor gitchur thinkin' caps back on 馃榿

-jokester
So I had mentioned the EGR valve, but what I found is that mine was cutting out and specific temp 196-198. I had an old wiring harness that I was going to overlay just to wires to the egr valve. When I cut into the old harness I found that where the harness routes in front of the oil filter, all wires were stuck together and hard. I ended up wrapping my current harness in heat sheild and my egr magically is working. It's been a week so far, I do still have the erratic idle but it's less and is pointing me in the direction of harness issue from heat. I have come across a relocation kit for the icp sensor( basically a hose that pulls the sensor away from the turbo heat.) I may try that as well when I get another harness.
 

Registered
Joined
471 Posts
I agree with you on the ICP. The FICM, when properly soldered, with quality components, just isn't an issue - IMO.
When I swapped my power supply with the bulletproof one, I loosened the cover plate and quite a bit of hot air escaped. Granted the truck had only sat for an hour but I would have put that in the cab. I spoke with ED from Ficmrepair and he said they were actually working on a relocation kit but it's alot more work then it seems.
 

Registered
Joined
471 Posts
I had one FICM failure at 65k miles (it was the original). After upgrading, there have been no problems (currently at 240k). I have been pushing some decent power since 100k miles. Lots of people w/ similar experiences.

I wouldn't doubt that the relocation kit would sell, but IMO it is just playing to peoples emotions....unless the relocation kit costs significantly less than a quality FICM upgrade costs.
My coworker went through 2 and when the second started going out, he sold the truck. I'm not convinced his was ever ficm or the dealership just kept charging him though.
 

Registered
Joined
471 Posts
I just bought an icp relocation line and found a 12" icp connector extension on a different site(so I don't need to open my wiring up). I'm going to try this and see if this also is a temperature issue. I could probably have just unplugged the icp but I like the idea of moving it as well. The icp v at idle when it acts up are .7 to 1.1 constantly fluctuating but only when truck is warm.
 

Registered
Joined
471 Posts
The icp relocation kit arrived yesterday along with the extension connector I found on a different site. It was about 5pm and I decided to try and install instead of doing it today since with all the experience I have of tearing everything down, it should be quick. I was so wrong. Teardown was fast. Install kicked my butt. You get an adapter fitting to go into the block, a 45 deg fitting to get to the hose(5100psi rated) then another adapter on the opposite end for the ICP sensor. Without removing the Turbo, there is no room for wrenches to tighten fittings, I fought for a good 2 hours trying to catch a thread by flicking my finger and holding it at the same time. I finally got it and just got back from getting gas. So far the truck is solid as a rock. I got back from a 250 mile trip yesterday and my truck pretty much was acting up at every stop. I'm still thinking my wiring or the sensor was being affected by heat. I will update after this week and @jokester00, maybe this is your issue as well. I also sleeved the relocation hose with my left over DEI heat sheild.
 
1 - 17 of 135 Posts
Top