Ford Powerstroke Diesel Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
612 Posts
Discussion Starter #1
(addendum to prior "Abusive streak" thread, in the prior thread I drove the 1600+ miles to work, cruised 75-80+ mph up hills on cruise control:rockwoot:). Coming home I pulled the 8,000 trailer, it was a 1719 mile trip, so I topped off the DEF tank to check consumption. I cruised home averaging 66.5 mph moving per Garmin. Halfway home, lost power, no 'warning lights, no warning messages', no overheating, truck ran okay, just no power to pass, no acceleration up hills, transmission did not shift correctly. Did not worry, as temps, basic functions were okay. Reminded me of a big block chevy with a restricted fuel filter, high rev's, no power. This morning, went to the dealer, had the fuel filters changed. Immediate benefit, this truck NEVER had this much power.
Took traction control off, locked the rear end, nailed it. It went sideways, straightened it out and left two rubber streaks for the salesmen to sell 2011's :scuffy.
(I drove my 6.0 like this, about 25% the distance or less, stretched headbolts. This truck was driven both ways, cruising 70 +, top speed per Gramin 84+ mph, up grades, over hills, 6400 elevation at times, no problems other than maintanance related fuel filters. No comparison to the stock 6.4, or the modded 6.0).

DEF?? Topped off the DEF tank, took less than 1 gallon for 1719 miles running hard.:thumb:

Lose power? Not to worry, recommend having the dealer change BOTH filters, or check spec's on which one to change first....
 

·
Registered
Joined
·
392 Posts
That's good to know.I drove 2011's today and loved it.I'll be picking one up in two weeks.
Thanks for the info :thumb:
 

·
Registered
Joined
·
99 Posts
I've been following you posts like a hawk based on the miles you are puting on your truck and the fact that you admit that you don't baby it (the way it should be) and was wondering what it is that you do or what are you hauling that requires such time sensitive attention. If you want you can PM me with the answer.


:icon_ford:
 

·
Registered
Joined
·
612 Posts
Discussion Starter #4
My job is the reason for my miles, with oftentimes being called to be somewhere within 48 hours or less for work. I have worked the East Coast, West Coast, and numerous locations in between. My vehicle is crucial, because in the absence of ice/snow I prefer to take the comforts of home, meaning my trailer with me. I will stay anywhere from 3 weeks, to three months. So having a truck that can haul arse pulling a load without breaking reduces stress. This 6.7 is the toughest truck I have ever driven, including my 7.3.
I work out of my truck, in heat it idles to keep the AC on all day, in cold weather, it idles to keep the heat on, at this writing, my idling hours more than double my driving hours.

I am getting ready to increase the trailer weight from 8k to over 10k with a 36' fifth wheel. :thumb:

These trucks are new, and there is a learning curve that is occurring. The 6.4 would still run great with a trashed fuel filter, the 6.7 will not.
Hopefully knowing this will alleviate frustration for others...
 

·
Registered
Joined
·
2,489 Posts
Wonder why the filter got plugged up so quickly? Might want to run another filter in the setup somewhere...Racor maybe?
 

·
Registered
Joined
·
8 Posts
Ford 6.7 diesel handbook: change fuel filters every 22,500 miles, except for frequent or extended idling change at 15,000 miles. Could be why they needed changing early.
 

·
Registered
Joined
·
82 Posts
How about a bad batch of fuel?? That would surely cause a filter to plug up early. Did you see what your old filters looked like?
 

·
Registered
Joined
·
612 Posts
Discussion Starter #8
No I did not check out the old, but loss of power was noticable after a fill up at an old gas/diesel filling station that had not been maintained, they possibly had not changed their filters...or...per the earlier post, my extended idling may have contributed.

My fuel filter message did not light up, it might be pegged to the mileage instead of performance.
 

·
Registered
Joined
·
82 Posts
No I did not check out the old, but loss of power was noticable after a fill up at an old gas/diesel filling station that had not been maintained, they possibly had not changed their filters...or...per the earlier post, my extended idling may have contributed.

My fuel filter message did not light up, it might be pegged to the mileage instead of performance.
The fuel station is probably the culprit, although the fact you got "more power" than you ever had is a little alarming.

I bet the fuel filter is pegged to gallons through it, rather than performance - sort of like how the "oil quality" computer works.
 
1 - 9 of 9 Posts
Top