Ford Powerstroke Diesel Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter #1
The first time I drove my truck I had to drive it for about an hour and a half for the filter to get clean. Blue screen came on that said filter cleaning was complete. Since then, the orange warning screen that’s says cleaning exhaust filter comes on for about 3 seconds and then just goes away. No other prompts that cleaning has been completed and no messages in the message center. Most of my driving is freeway for an hour at a time. Is this normal or does it sound like there is a problem with the SCR system?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
483 Posts
sounds like my 2015 6.7

Just a quick let me know it's doing it, but I already feel it in the throttle before the warning comes on. I also feel it in the throttle when it's done.
 

·
Premium Member
Joined
·
44 Posts
Same here - 2016.

Sounds normal to me. I have never gotten any message that says the cleaning cycle is complete.

The info the stock display gives is pretty minimal. I use an Edge cts2 monitor.
 

·
Registered
Joined
·
1,796 Posts
No menu pops up to let you know it's complete. Whatever box you saw, wasn't for the regen completing.
 

·
Registered
Joined
·
214 Posts
If you have the 4" info display between the gauges you can have a third screen turned on in the Information Section as I recall, that shows the % the filters is clogged and you can watch it clean as you drive.

There are a number of threads on this.

Tom
 

·
Registered
Joined
·
56 Posts
Discussion Starter #6
The first time I regened the truck, it said the filter was clogged. After driving a blue screen came up saying the process was completed. I haven’t seen it since but maybe that’s because the filter hasn’t clogged again. I do have the lariat display screen as well.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
263 Posts
Just hopping in on this thread so sorry if it is unrelated. I just picked up a new to me 16 XLT and had it for 2 days. I don't have the nice info screen in the gauges like you guys but I had a message flash saying exhaust cleaning taking place or something like that, right as I was getting home. I shut the truck off because we are about to go to the lake and will be on a roughly hour to hour and a half trip. That should be enough time for it to regen shouldn't it? Will it go into passive regen when we leave here shortly?

Thanks for the help.
 

·
Registered
Joined
·
1,796 Posts
Depends how clogged it is to go right into regen when you first turn it on. When you start driving it will reach its % to start the cycle. A regen for my truck if it was 90% would take about 20 minutes of driving on the highway.
 

·
Registered
Joined
·
133 Posts
sounds like my 2015 6.7

Just a quick let me know it's doing it, but I already feel it in the throttle before the warning comes on. I also feel it in the throttle when it's done.
Same with mine. It seems sluggish before, then goes back to snappy after. I may have to delete to keep the snappy and I have been considering it since I dont have to e-test her here in Colorado(I'm surprised!!!)
 

·
Registered
Joined
·
522 Posts
I have a 15 also. It isn't capable to show the percentage of the DPF. I guess an older model can. On the screen with the compass if you scroll to the right is the percentage screen. Mine is blank. I can't do an operator regen either. I wish I could as I rarely get to do a complete regen. So I guess it does regens in stages. I read that with Forscan you can do forced regens parked in your driveway. I haven't had the time to figure that out though.
 

·
Registered
Joined
·
33 Posts
I have a 15 also. It isn't capable to show the percentage of the DPF. I guess an older model can. On the screen with the compass if you scroll to the right is the percentage screen. Mine is blank. I can't do an operator regen either. I wish I could as I rarely get to do a complete regen. So I guess it does regens in stages. I read that with Forscan you can do forced regens parked in your driveway. I haven't had the time to figure that out though.
You can enable the dpf% screen with forscan. Theres another thread stickied here with instructions about how to do it. Its pretty easy.
 
1 - 11 of 11 Posts
Top