Ford Powerstroke Diesel Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
I have a 95 F350 7.3.. So yesterday I go in my truck to move it and the chrome piece around the ignition fell off, no big deal to me, I proceeded to get in put the key in and turn it for the "wait to start" I had no resistance in the key in doing so which I thought was odd, so I figured o well. Got the truck started moved it turned the key to off and it continued to run so I pulled the fuse to shut it down.. I bought a new ignition switch and replaced the old. It felt fine at "off" position continued to turn it to "run" again no resistance??? Turned it back to off and all the dash lights abs etc continued to stay on like the key was in the "on" position but the key was out? What could this be, It seems like a moving part but I can't figure it out, I hope someone can help!!!!


Sent from AutoGuide.com App
 

·
Registered
Joined
·
537 Posts
Never had one apart, but I would guess that the chrome piece engages the rod that connects the lock cylinder to the switch at the base of the column.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #3
I replaced the lock cylinder not the switch is what I meant, I am thinking the rod is broke but I won't know until I dig I tomorrow I have no idea what what party would be called and how the *%#* do you get to it??


Sent from AutoGuide.com App
 

·
Registered
Joined
·
506 Posts
I think it is the ignition switch actuator rod or something, turn the key, and feel on the switch if the rod is moving. If not you might have to take the steering column apart and investigate.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #5
Yea the rod is definitely broken in half I'm guessing will a little work I have most of the column apart I just can't figure out how to get to the rod or remove the rod? ImageUploadedByAutoGuide1379264754.292804.jpg
ImageUploadedByAutoGuide1379264764.001153.jpg


Sent from AutoGuide.com App
 

·
Registered
Joined
·
21 Posts
Discussion Starter #6
Ok so I finally got around to doing some more searching got the column apart and well the actuator had a pin that connected to another piece of the actuator pulled it out did some grinding to try and get the pin not to come back out, I was hoping I could get a small pin with a clip on the on side to keep it in there, any suggestions??


Sent from AutoGuide.com App
 
1 - 10 of 10 Posts
Top