Ford Powerstroke Diesel Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1 (Edited)
Truck lost power acted like it wanted to die while driving (acted like it ran out of fuel), turned key on and listened for fuel pump (can always hear it) and nothing. After putting 4 more gallons of fuel in it just to be sure it had fuel I tried driving it some more, sputtered terribly, couldn't go over about 10mph, pulled over and cycled the key a couple more times while listening for pump (no sound), then I get down and feel the pump and its HOT, REAL HOT. So I figure its fried, getting power obviously but not turning on at all (had a friend turn key while I listened right next to it also).
Today I made sure by draining what was left of fuel bowl, cycling key, opening fuel bowl valve and got nothing. A friend and I changed the pump, when we disconnected the fuel line on the tank side of the pump, it had fuel coming out of it, but not pouring like you would think since we know their fuel in the tank. We proceeded anyways, cycled key about 4 times and the new pump was running loud and strong, truck fired right up but not running completely normal, it had that extra "clack" like it was not getting full fuel flow, shut it down and cycled pump a bunch more, tried to start and it wouldn't even idle, loping bad, no fuel in bowl. We cycle the key a bunch more times, open valve, cycle key, open valve, nothing, no fuel in bowl. Disconnected fuel line on tank side, NO FUEL AT ALL

So I know about screens being in the tank, I'm really trying not to have to pull the tank. I blew into the tank, at first felt a little clogged, but then felt pretty free and was bubbling in the tank like crazy through the fuel, stopped blowing, we hooked the line back up and cycled with valve open on bowl a few more times with no fuel even though new pump is running, sounds like pump is just sucking air...?
Any and all help is really appreciated, I realllllllly don't want to drop the tank right now

As of right now I'm planning on using compressed air from the pump into the tank to be sure its not clogged at all but when I blow in it myself it doesn't really feel clogged. Any reason compressed air would hurt anything? Just screens in between pump and tank correct? Thanks everyone!
 

·
Registered
Joined
·
26 Posts
Discussion Starter #2 (Edited)
UPDATE:
I hooked a short hose to tank side of the new fuel pump, its running but not sucking a drop...POS airtex from autozone not working I guess.

ANOTHER UPDATE:
Got another one, this time from O'reilys but same airtex brand, this one looked like it had been installed before...also had a different (cheesier type) sleeve. Hooked it up and ran just straight hose from both sides, one into a bucket one from a glass of fuel, pump has good power and sounds as if its running like crazy but its not sucking/pumping a drop...
This is 2!! Whats goin on here!?

And Another Update: got yet Another one, same dang brand, going to hook up test hoses right away and test this pos, third time the charm?

EDIT: this one is not sucking either, what the heck am I doing wrong!?!?!? someone plz help
this is how I'm testing it...line on right going to bucket, line on left of pic going to glass of fuel...this should be sucking it from glass and pumping it out the other side correct!?




EDIT LAST TIME:
hey gee thanks for all the help guys...turned out to be those stupid airtex pumps
whoever said third times the charm was wrong, 4th fuel pump was the charm, ended up with napa's and runs like new
What a lesson, Airtex sucks (but not literally)

Hopefully this will help someone someday, otherwise I wasted my time even posting it on this forum
 

·
Registered
Joined
·
827 Posts
Hey man glad you got it figured out. I wouldn't of been much help. Sounds like replacing the pump is pretty easy...once you get a good one lol im gonna replace mine in the near future and def won't be buying any cheap pumps lol

Sent from my DROID X2 using AutoGuide App
 
1 - 3 of 3 Posts
Top