Ford Powerstroke Diesel Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have an excursion 6.0 diesel power stroke and it won’t crank . I had a mechanic hook it up to the comp and it showed abs/brake module faulty. I really don’t want to end up at the dealer . Any assistance with this matter is highly appreciated.
 

·
Premium Member
Joined
·
4,408 Posts
wont crank = engine does not rotate when you try to start it
is this the symptom?

Get your own "scanner" so you dont needlessly throw money/parts at the problem

ForScan and the BAFX or OBDLink MX+ work well with these trucks and is inexpensive
you do not need the extended license to use ForScan -- the PC version is the most in depth, but the "lite" version will work well for troubleshooting

 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
ABS no crank ?
Excursions have a security module and PATS key are u sure thats not the issue ?
Yes I think your right . i meant to say the truck won’t start when you turn the key . When I turn key anti theft light flashes .
 

·
Premium Member
Joined
·
4,408 Posts
You are using the key that has been starting the vehicle?
Does the key fob lock/unlock the doors?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
You are using the key that has been starting the vehicle?
Does the key fob lock/unlock the doors?
Yes same key but the fob is aftermarket. It has an alarm system. Everything works on it but when u turn the key, it does nothing and anti theft light flashes. I had a locksmith to see if it was the key but it’s not .
 

·
Premium Member
Joined
·
4,408 Posts
The anti theft light you speak of is the factory light on the dash? (instrument cluster light and on top of the dash)
is this an aftermarket alarm or factory?

The reason I asked about the door operation earlier is because the VSM(vehicle security module) is what operates the door locks -- looks like it has power
 

·
Administrator
Joined
·
30,450 Posts
I think it is the PATS not letting the truck start

the remote can open the door no problem but if the PATS does not recognize the key chip it won't crank

no spare keys ?
 

·
Premium Member
Joined
·
4,408 Posts
The PATS would activate the light on the dash and the light on the sun load sensor -- was trying to determine if those were the lights or an aftermarket setup was what he is looking at

the sense coil around the key tumbler for the PATS system could be out of place or the chip in the key(rare) could have stopped working, especially if the keys are handled rough

since the door locks operate, it is likely the VSM is working

hmm -- still need to determine if the alarm is factory or aftermarket
 
  • Like
Reactions: ZMANN

·
Administrator
Joined
·
30,450 Posts
why are we hung up on aftermarket alarms ? ( by we I mean you,,,,,, lol just kidding )
he has the pats key and the dash is " anti theft light flashes " that tells me it is the cluster display showing car padlock

that tells me regardless of the status of the aftermarket alarm the PATS is not reading the key

if it was mine i would read the pats module with my AE software to see if it has issues
worst case is have two OEM keys programmed to the module

or i think the latest forscan can do it
 

·
Administrator
Joined
·
30,450 Posts
this is why two keys are best and not a fan of the aftermarket ones for various reasons
 

·
Premium Member
Joined
·
4,408 Posts
"When I turn key anti theft light flashes "
I suppose it depends on where this light is located - @ZMANN
I read it as possible aftermarket, but maybe jumped the gun a little 🍺

yeah, forscan or ae should be used to read the pats system to see if it is working

would not be a good idea to try to program a key unless the system is operational
you need at least one working key todo that

forscan will do the programming
 
  • Like
Reactions: ZMANN

·
Administrator
Joined
·
30,450 Posts
I think you can program with this PATS with 0 operational keys unlike some vehicles that need 1 non clone

the Ford dealer would have to do two keys from what i read

you would need two operational to add more keys without starting from scratch
 

·
Registered
Joined
·
5 Posts
Discussion Starter #14
The anti theft light you speak of is the factory light on the dash? (instrument cluster light and on top of the dash)
is this an aftermarket alarm or factory?

The reason I asked about the door operation earlier is because the VSM(vehicle security module) is what operates the door locks -- looks like it has power
The PATS would activate the light on the dash and the light on the sun load sensor -- was trying to determine if those were the lights or an aftermarket setup was what he is looking at

the sense coil around the key tumbler for the PATS system could be out of place or the chip in the key(rare) could have stopped working, especially if the keys are handled rough

since the door locks operate, it is likely the VSM is working

hmm -- still need to determine if the alarm is factory or aftermarket
Yes the anti theft light is on the dash on top.
The alarm it has is aftermarket. The door locks work , even the key pad on door works. Btw I really appreciate all the help you guys are providing!
 

·
Premium Member
Joined
·
4,408 Posts
Put the key in the ignition and turn it to the run position. Theft indicator proves out after 2 seconds and then flashes rapidly. After 15 minutes of flashing, The theft indicator will stop flashing. Within/Before a few minutes (5 I believe), after it has stopped, turn the key off and then back to run.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #17
Yes the anti theft light is on the dash on top.
The alarm it has is aftermarket. The door locks work , even the key pad on door works. Btw I really appreciate all the help you guys are providing!
no spare key?
does it have remote start ?
Put the key in the ignition and turn it to the run position. Theft indicator proves out after 2 seconds and then flashes rapidly. After 15 minutes of flashing, The theft indicator will stop flashing. Within/Before a few minutes (5 I believe), after it has stopped, turn the key off and then back to run.
finally figured out the problem . The Ecm Is burnt out. Trying to find a replacement. Any suggestions?
771077
 

·
Compression Ignition Addict
Joined
·
6,620 Posts
I would look for a shorted out wiring harness in the fan clutch wiring based on the pins that look "burnt".
 
1 - 20 of 22 Posts
Top