Ford Powerstroke Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
138 Posts
Discussion Starter #1
Hey ya'll. So my 05 has some weird stuff going on. I'll see if I can explain this.

So, a couple weeks ago I was driving my truck and all of a sudden when I pull away from a stop sign I get this rubbing, rattling sound coming from what felt like the front end. Went to turn around and head back home and it went away. Now, I'm getting this rubbing sound when I turn the truck and the body rolls some. I.E., going uphill and turning, particularly left. I had a built camaro that was notorious for busting the transmission mount so when I went to turn the driveshaft would "rub" the transmission tunnel. That kind of sound. I have been under the truck and do not see any sign of this occurring. I checked the transmission mounts and they looked good. It has also done it after I hit a hard bump.

Any clue?
 

·
Premium Member
Joined
·
11,713 Posts
Probably the down-pipe hitting the body seam. You should be able to adjust it, but if your cab bushings are badly worn, that could be an issue too.
 
  • Like
Reactions: jokester00

·
Premium Member
Joined
·
2,197 Posts
^^^THIS!!

Pay close attention to where the exhaust pipe runs above the transmission crossmember - a 4" exhaust is VERY tight to those bolt heads. Mine has done exactly that and only when turning left. Sounds like a tire rubbing on something in the wheel well when mine does it.

-jokester
 

·
Registered
Joined
·
60 Posts
It can also rub against the rear shackle on the leaf spring ( my 04), my 4" was doing the same thing but they are also correct on it rubbing against the frame rail.
 
1 - 5 of 5 Posts
Top