Ford Powerstroke Diesel Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
I have an 04 6.0 with 162000 mi. All injectors, heads, gaskets, were done at 100k. I was towing a dump trailer with a heavy load of asphalt the other day. After dumping it I noticed the engine began running really rough so having roadside assistance and knowing the problems created by driving when unnecessary, i had it towed to my buddys shop. Pulled EGR valve out and cleaned it and it did no good. He has Auto Enginuity but we cant figure out how to monitor the HPOP. The truck will start fine, but after running a few minutes, it starts running really rough and will eventually refuse to start. The normal high pitch whine from the turbo (reman) and exhaust will began to sound very choppy. Truck will actually begin to shake. Not much smoke at all really like it did with injector issues. I am assuming the viscosity breakdown is the reason for the rough running when it warms up. I have been noticing a quarter spot of oil in the driveway for a while now coming from the area of the HPOP. I lost my job and really cant afford to throw parts at it. How can I pinpoint the problem? Figured i'd do an EGR delete while I'm in there and was noticing that there are some kits for 150 on EBAY that seem to have all of the compnents of the other more expensive companies. Are they fine? Also, what other budget upgrades and seals/orings should I complete while having the turbo off? Sorry so many questions, but I had to vent somewhere. Thanks for all of your time and help. Here we go again.
 
1 - 1 of 1 Posts
Top