Ford Powerstroke Diesel Forum banner

1 - 5 of 5 Posts

·
Premium Member
Joined
·
556 Posts
Discussion Starter #1
I just installed a set of the retro-solutions projector retrofits on the truck and for the life of me cant get the passenger side light to come on regularly. Most times it makes a very fast three buzz noise (da-da-da) and that's it. In fact, the noise is coming through the entire truck (seems like I can hear it at the switch, but I can also hear it by the ballast and the light itself), which may have something to do with how I wired it. Does this sound like a ground issue? I have it grounded directly to each battery, which was the quickest ground I could find (not easy under this new hood). If I take the fuse out and plug it back in a few times I can get the light to work. Driver's side goes just fine
:tard:
 

·
Registered
Joined
·
108 Posts
i had a ground issue where 1 light would be out.I cleaned up my grounds and used plenty of dielectric.I grounded to the core support
 

·
Registered
Joined
·
3,177 Posts
What kinda hids are they when I did mine I used the factory head light wiring and just plugged them in there are they a single beam hid or high and low beam if single where u do have them wired to
 

·
Registered
Joined
·
108 Posts
I have retro solutions hid bixenon retrofit. mine plug right in to the factory wiring but have a power lead which went to the battery and the grounds which where shorter I put on the left and right radiator support.I drilled the 2 holes ground to bare metal and loaded up with dielectric and used self tapping bolts
 

·
Registered
Joined
·
189 Posts
Had the same problem find a better ground and you will be good to go...
 
1 - 5 of 5 Posts
Top