Ford Powerstroke Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
144 Posts
Discussion Starter #1
Today was the day to do some needed work on my tranny. I bought the truck 6 months at a with 142 on the clock. After doing a lot of reading on this forum I decided I needed to upgrade the pan and internal filtee as well as the direct clutch solenoid and dummy plug. After I dropped the pan I wanted to wipe everything down really good before I moved the pan out of the way to prevent any drips. As you'll notice in the photos everything had a dark film on it. It was hard to tell if it was metallic or not but, it was concerning to me. After I moved the pan out I looked in and was shocked at the amount of material on the magnet. I know that is what the magnet is there for and it did it's job well I just didn't expect so much. I didn't find any large pieces just real fine. I'm not having any tranny issues at this point but, I'm just wondering how concerned I should be. BTW this is an 06 with 150 in the clock. This is my first pan drop ever, am I just overly paranoid? Thanks for your comments.


Sent from my LG-LS993 using Tapatalk
 

·
Premium Member
Joined
·
11,686 Posts
Looks like a 140k transmission to me. Probably looked pretty similar at 10k.
 

·
Registered
Joined
·
191 Posts
Yea don’t worry about that. You don’t have any big pieces so I wouldn’t worry about it


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
144 Posts
Discussion Starter #4
Thanks for the help guys. I've never been into one before. I was expecting to find some stuff in there but I didn't expect that much stuff. You have made my day.

Sent from my LG-LS993 using Tapatalk
 
1 - 4 of 4 Posts
Top