Ford Powerstroke Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1 (Edited)
I am chasing a high pressure oil leak on my 05 f250. I replaced my hpop and fittings from ford it is still not building oil pressure . After testing the system with air though the valve on the passenger side valve cover . It sounds like it was coming from under that valve cover . After removing the valve cover and testing again it sounded like it was coming from the stand pipe area . I removed the oil rail and inspected the stand pipe and oring they were good ( new design replaced a month ago when HG and studs were done ) . I check the rest of the stand pipe still in the block with air pressure using a rubber tip nozzle and air blows back out around the stand pipe. Is that supposed to happen ? I fugured it should be sealed . What could be leaking in there . The stand pipe is sealed bellow it very well .

This truck was runnning when I replaced the headgaskets and studs . Now it will not build high oil pressure. Replaced HPOP ,STC fitting ( came already on the pump) and IPC valve and screen because it was diry and had a small hole . Verified low pressure oil with mechanicle guage. What should I be looking at now ?
 

·
Registered
Joined
·
74 Posts
It sounds like you had just the check valve part if the stand pipe come out. The oil rail on top of the injectors holds the rest of the stand pipe tight to the block with the check valve tightened into the rail. I had a similar problem with mine and found that an oring in the top of one injector was bad. Check those orings. Ford says you can not get just the orings and have to get the whole injector but I have found them on ebay for like 20 buck for all 8
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3
All top injector orings look good. The air seems to from inside the block where the tube exitsthe head. The seal around the tube to the oil rail is good . Could this be coming from the new High pressure oil pump. What else is in there that could be leaking ?:dunno:
 

·
Registered
Joined
·
118 Posts
Ipr?


Sent from my Autoguide iPhone app
 

·
Registered
Joined
·
74 Posts
The only other place that could be leaking is the branch tubes that feed the rails. That is where the stand pipes go into. I havnt heard of too many that have cracked but it is possible. They are a SOB to get to. Either cab off or tranny out in order to get to since you have to remove the rear cover.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #6
IRP and screen were replaced at the same time as HPOP. How to I check to verify if it is a branch tube leak ? Do I remove the HPOP housing and pump to verify leak .
 
1 - 6 of 6 Posts
Top