Ford Powerstroke Diesel Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
368 Posts
Discussion Starter #1
i just recently installed a pair of hid lights in my fog lamps and when i turned them on it blew the fuse... the fuse size is only a 10. i put a 15 in and it blew that too..so i put a 20 in and it didnt blow..do you think its safe to keep that or will i melt my wiring? and why is it blowing the 10 fuse?
also i dont think i have a short cuz when i put the stock lights in it doesnt blow the fuse.
 

·
Registered
Joined
·
804 Posts
hid requires alot more power.
 

·
Registered
Joined
·
368 Posts
Discussion Starter #3
so what do i do about it blowing the fuse? just keep a 20 in?
 

·
PIPE HITTER
Joined
·
1,472 Posts
hid requires alot more power.
Actually it is the the opposite. An HID's will only draw about 3 amps at operating current. If you are blowing a 10amp fuse, you may have a wireing issue, or it could be a bad ballast/ignitor.

Do they blow the fuse in startup, or after they have been on a while?
 

·
Registered
Joined
·
368 Posts
Discussion Starter #6
they blow the fuse on startup..they dont blow a 15..i tried it again but it does blow the 10..i dont think theres a problem with a 15 amp considering thats what the regular headlights have for a fuse...?
 

·
PIPE HITTER
Joined
·
1,472 Posts
they blow the fuse on startup..they dont blow a 15..i tried it again but it does blow the 10..i dont think theres a problem with a 15 amp considering thats what the regular headlights have for a fuse...?
Depending on the ballast, they may draw as much as 18amps at startup, sounds like that what you are gettin, just a current spike, if the 15 amp works, roll with, you should be just fine.
 

·
Registered
Joined
·
262 Posts
not to hijack too much.. what size/ type did you get & how bright are they, I have blackouts on my headlights, and only use my fogs for light. (with truck being so high anyway)
 

·
PIPE HITTER
Joined
·
1,472 Posts
4300K would have the most output. it will go lower the higher in color temp you get (K) 4300 or 6000K are your best bet.
 

·
Registered
Joined
·
368 Posts
Discussion Starter #12
xenon and there 10k and there bright enough to drive with just the fog lights on..i can see more with just my fog lights on then just my headlights (10k)..and together there awsome
 

·
Registered
Joined
·
262 Posts
yeah, I already have a set at 8000, they are nice, but the fogs are just the normal 25w, I am looking for more wattage, anyone know what fits it?? I was looking at HID for the power save, & figured they would not get as hot, temp wise
 

·
PIPE HITTER
Joined
·
1,472 Posts
yeah, I already have a set at 8000, they are nice, but the fogs are just the normal 25w, I am looking for more wattage, anyone know what fits it?? I was looking at HID for the power save, & figured they would not get as hot, temp wise
Fogs are H10's
 

·
Registered
Joined
·
196 Posts
i have a set of yellow 3000K hid's for the stock foglights that I need to sell. Got a new bumper so I didn't end up using the stock fogs. PM me if any of you are looking for some. They're brand new.
 

·
Registered
Joined
·
786 Posts
I installed mine and it said that start up with two will require more starting amps. They recommended 20 amp fuse, and said 25 is safe if needed. It's just starting amps, I think its like 9 amps starting. If you disable one HID and start with a 10 you'll be fine.
 

·
Registered
Joined
·
302 Posts
im with 04stroke i just installed xeon kits in the fogs and headlamps and its just sick i'm running 12k i haven't had any fuse problems i think that the xeon kits are one of the nicer ones out there
 

·
Registered
Joined
·
302 Posts
from a shop by me called first bass the phone number is 412.3530631 they have an 18 month warrenty and I belive they are like 229.00 a set
 
1 - 20 of 26 Posts
Top