Ford Powerstroke Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
02 7.3L w/66K miles. The other day while I was driving the low fuel alarm sounded and the fuel gauge went to empty (3/4 tank of fuel). I stopped and shut the truck off/restarted it and it went back to normal. 1/2 mile down the road it did it again. Restarted it and it has been fine ever since ..... until today. Started the truck fine...while warming up it started to run a little rough, I went to leave the driveway and it ran really rough and blue smoke out exhaust bad. I shut it off and restarted it. It smoked bad and idled really rough. Drained the filter and tried again. It barely wanted to start. Still runs very rough?? Wants to die!!! Any thoughts????? CPS changed already. Fuel filter changed at 50K. Can't drive it.
 

·
Premium Member
Joined
·
9,603 Posts
Probably have a faulty sending unit. Try putting some fuel in it and see if it continues.
 

·
Registered
Joined
·
3,383 Posts
You stated fuel filter changed at 50k, I always change my fuel filter with my oil filter. 16k sounds like a lot of miles on one fuel filter...
 

·
Premium Member
Joined
·
3,578 Posts
Wonder if you may have gotten a bad load of fuel?
I change my fuel filter every 8,000 miles or so, 16,000 is double what I would go.
There is also a mixing chamber in the tank that can get stopped up.
A fuel pressure test would rule out and fuel problems.
Here is a look at my filter with about 8,000 on it, sometime during that 8,000 I got at least one bad load of fuel. alabamafrog/Powerstroke Fuel system - Photobucket - Video and Image Hosting
 
1 - 4 of 4 Posts
Top