Ford Powerstroke Diesel Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter #1
I have a completly stock 04 F350 6.0L 120,000miles
6 months ago replaced radiator and 1 year ago the degas bottle. (I broke the radiator overflow nipple ARrr) and degas bottle had cracked.

I smell antifreeze when the truck is pulling a trailer under load.(2500RPM's up the interstate on ramp) No other time.

I see a small amount of white powder around the overflow (Degas bottle?) cap. There are no other visible leaks.
I read that I should pull the hose, truck running/at operating temp, that goes from the manifold to the bottle and see if there is any flow.
There is a slow steady flow.
Seems the thread I read stated this is a problem. Stretched head bolts??
Any thoughts or direction is appreciated.
 

·
Registered
Joined
·
76 Posts
Discussion Starter #3
Removed EGR valve. Slight build up on EGR. easy to clean. Manifold had minimal carbon buildup. How wet are we talking? I took a scraping. It looks more oily then wet, but only slightly. Can you elaborate on cap venting while boosting? I hear no abnormal noises when I smell the antifreeze. Could something be blocked and when the rpm's go up the system backs up and vents fluid??
 

·
Premium Member
Joined
·
6,293 Posts
Take the truck out for a drive and get it up to operating temps.
Then, park it on an incline, nose down. Remove the EGR valve again.
Leave like this overnight. In the morning, check the hole again. If you find ANY moisture, your egr cooler has failed.
 

·
Registered
Joined
·
36 Posts
Hey Guys-what about oil cooler clogging causing flash heating in EGR cooler due to low coolant flow there, couldn't this cause vent cap boosting? I am wondering cuz I had same problem also only when towing load. Codes came up P0404 and P1335 with engine coolant temp/oil temp of 212/242 (driving empty). Replaced oil cooler and EGR cooler and appears to have fixed it. EGR valve was dry but intermitttenly sticking open so changed it too.
 

·
Registered
Joined
·
36 Posts
maybe piratejonh, if you have gauges/scantool you would wanna check your temps out.

your gonna wanna change out both coolers anyway if one has failed(Ford TSB 09-8-3),

and if you wind up having to do head gaskets. your probably gonna wanna change

coolers out while your in there as well. Be sure to check out NYC's link above "Basic

Info for the 6.0 owner.
 

·
Premium Member
Joined
·
6,293 Posts
Hey Guys-what about oil cooler clogging causing flash heating in EGR cooler due to low coolant flow there, couldn't this cause vent cap boosting?
Nope, well not at that time, but it is well on its way at that point. The coolant will "puke" once the EGR cooler has failed internally. What you mention above is what causes the EGR cooler failure.
 

·
Registered
Joined
·
10 Posts
Hey piratejonh, I just went through this last nov.among other issues with my 04 F-350 .
I went to BULLETPROOFDIESEL.COM and watched all the videos on the issues with these trucks . I ended up replacing my oil cooler and egr cooler with there complete package ,comes with complete instructions and great tech support if you end up doing it yourself .
 

·
Registered
Joined
·
28 Posts
hey guys, i see this is an old thread but i think the issue is the same.
i have an 04 f250 4x4, EGR delete, appears to have Aftermarket turbo. unsure if has a new oil cooler as all this work has been done prior to my owning the vehicle.
one day on way to work Temp went up and i shut off before it got 3/4 the way up on gauge. coolant puking out of degas tank.
ended up having to replace the FICM, degas tank and cap, and seemed to fix the puking for a time. does not do it all the time. i have read about leaving fluid slightly low to account for expansion so i have done that. also heard if HG is bad to see if antifreeze smells of diesel and mine dont. i would love any help with this before i pull heads and tackle that task.
 

·
Premium Member
Joined
·
3,940 Posts
What's your coolant temperature doing? Is it staying in the normal range? Has the thermostat been changed?


Sent from AutoGuide.com App
 

·
Registered
Joined
·
28 Posts
Temp is staying in middle and yes i changed the thermostat. has only done it 2 times since the thermsotat and the degas tank have been replaced. but i noticed the upper hose is getting hard but not solid.
 

·
Registered
Joined
·
28 Posts
the temp only went up 2 times before i changed the thermostat. no it stays good, and has puked a little bit 2-3 times. i drove it today and it didn't give me any issues. i did 75 on highway with no issues. not sure when it is doing it. and now when cold the fluid is pretty low. when hot it is jsut below the max line. maybe if the level gets low enough i will have no issues.
 
1 - 12 of 12 Posts
Top