Ford Powerstroke Diesel Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
This is a 2000 250 7.3 ltr. Lately this truck has been acting odd. It puffs white smoke on startup (white smoke) and sometimes it idles rough. The smoke goes away after a minute or so. I tried driving it and the vehicle would just shake the hell, like it was not running on all cylinders? I was going down the highway at around 50 and everytime i would accelerate it would just shake.
About 3 miles later it just went back to normal? I am at a complete loss i took it into a shop yesterday and he said everything looks good accept for a sensor he replaces on the valve cover i believe? he said it had something to do with the control of the injectors? I am new to diesels and am really starting to freak out htinking it is gonna cost me an arm and a leg. I hope this information helps out, I am just looking for suggestions from all of you who have axperience with these engines?
 

·
duct tape & zip ties
Joined
·
10,761 Posts
He most likely replaced the IDM ( Injector Drive Module). But by the way it sounds you may have injector o-rings that are bad causing the problem. Maybe a bad injector that needs to be replaced. Could be the UVC ( under valve cover ) wiring harness has a short in it. Which can cause the problem. I suggest you have a cylinder contribution test done. As well as an injector buzz test done. Also have the vehicle scanned for codes.
 

·
duct tape & zip ties
Joined
·
10,761 Posts
What was he using to check for codes. Some code scanners will not read DTC's for a diesel. But being at a shop I hope he would have the equipment to properly diagnose the problem.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
I am not quite sure what he was using? I know that he also checked the continuity of the glow plugs and they checked out! I was just reading a forum about having low oil my dipstick is about a half inch low could this have something to do with it? It has Rotella oil in it should i make a change maybe thiscould have somehting to do with it?
 

·
duct tape & zip ties
Joined
·
10,761 Posts
You could try changing the oil. It has been known that dirty oil can cause the engine to run rough. But your problem is more likely an injector problem. Possible that your HPOP (high pressure oil pump) is not providing the proper oil pressure. May need new o-rings for the Hpop, you can also check the Hpop oil level. You have to remove the plastic cover that says powerstroke on it. Under that cover will be to allen head plugs. Remove them and you can check the HPOP level. See if the level is full or not.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
It appears the the oil in the hpop deal is about 1 inch low from the top of the hole so it does not look low to me?
 

·
duct tape & zip ties
Joined
·
10,761 Posts
It appears the the oil in the hpop deal is about 1 inch low from the top of the hole so it does not look low to me?
Fill it up with the same oil you use in the engine. Fill the engine oil as well to the proper mark. See if that cures the problem.
 

·
duct tape & zip ties
Joined
·
10,761 Posts
So i should fill it so the oil is hitting the bottom of that little fill hole?
Yes if you are an inch below the bottom of the fill hole then you are low. Which maybe because of your low engine oil.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #11
It is an inch from the top so more like a half inch low maybe less but that would make a difference?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #13
I tried filling in that small hole in the hpop and it took a lot of oil and still in not to the bottom of that hole? the truck was about 2 quarts low and that other deal took about a quart and still not there? bad?
 

·
duct tape & zip ties
Joined
·
10,761 Posts
I tried filling in that small hole in the hpop and it took a lot of oil and still in not to the bottom of that hole? the truck was about 2 quarts low and that other deal took about a quart and still not there? bad?
If you are that low then I would be looking for leaks. Or your burning oil.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #15
well there is no oil under the truck ever so do you think because the truck is chipped it makes burning oil more succeptable? i will have to wait until the truck sits overnight to tell if anything has changed because when i just drove it it was fine!
 

·
Registered
Joined
·
10 Posts
Discussion Starter #16
I appreciate all your help BigCountry I will post tomorrow and let you know how the P.O.S. is running! hahaha Thanks Again man.
 
1 - 16 of 16 Posts
Top