Ford Powerstroke Diesel Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
26 Posts
not sure if this will help or not but....i just picked up a 99 f-250. my ebrake wasn't working. i crawled under the rear and adjusted the parking brakes. if ya look on the inside of the back of your wheel/drum....you'll see and oval shaped rubber plug (provided the plug is still there!) anyway...remove the plug and inside there will be a 'star' nut thingy lol grap yourself a flat head screwdriver and tighten that nut. repeat for opposite side. my parking brake is working just peachy now...
hope this helps!
 

·
Registered
Joined
·
26 Posts
do exactly did you tighten that thing? I couldnt find a way for the life of me to tighten that thing.

the nut in there is "star" shaped....i used a flathead screwdriver. got to stick the screwdriver head into the 'v' and spin it that way. won't take many turns to tighten....

when you look into the oval opening....you're looking at the side of the 'star' shaped nut....

help any? don't know how else to explain it????

:dunno:
 

·
Registered
Joined
·
26 Posts
the nut in there is "star" shaped....i used a flathead screwdriver. got to stick the screwdriver head into the 'v' and spin it that way. won't take many turns to tighten....

when you look into the oval opening....you're looking at the side of the 'star' shaped nut....

help any? don't know how else to explain it????

:dunno:

and "tighten" is a bad word to use also. i should have said "adjust". you want to tighten that nut, but you shouldn't expect to turn it to a point that it won't turn anymore....feelin me?

just give each side a few turns and then try your parking brake to see if it holds any better......
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top