Ford Powerstroke Diesel Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter #1
This weekend was the first time in over a year I towed with my PSD. I have a small 22 foot camping trailer that has a dry weight of 3900 lbs. The tanks were empty so lets be generous and say my wife packed over 1,000 lbs of stuff in it, I am towing 5,000 lbs.

On the freeway it felt like I didnt have much power but when I hit the canyon it really sucked. Going up the canyon I had to drop all the way into 2nd gear and could barely maintain 35mph. My EGT's, tranny temp, engine temp, oil pressure all looked fine. My turbo was making a chirping or squeeling noise but It has done that before. I was told that was the turbo surge that makes that noise. I have heard that noise before but had plenty of power in the past. No engine light or any signs of trouble, just no power.

My bro-inlaw has a 3/4 ton Chev w/ a 6.0 gasser and he blew past me pulling his 30 foot fith wheel like I was standing still. Usually I have to wait for him but not today.

Fresh motor oil, new fluids all the way around, diff, tranny, transfer etc. 200 miles ago. New fuel filter 1,500 miles ago.

Anyone have any ideas what I can start looking for ????
 

·
Registered
Joined
·
73 Posts
so you have a boost meter? your probably leaking boost out of an intercooler pipe
 

·
Registered
Joined
·
82 Posts
Discussion Starter #4
I had between 16-18 lbs of boost @ 3000 rpm in 2nd gear
 

·
Registered
Joined
·
601 Posts
sounds like some sort of fuel delivery problem
 

·
Registered
Joined
·
82 Posts
Discussion Starter #7
Well the tow back went a little better. I am hoping I got some crappy fuel. I filled up about 3 weeks ago in anticipation of this trip and added some cetane booster. I have not drove it since the fill up other than just back to the house.

On the way there horrible power up the first 2 canyons about 150 miles. I was down to almost 1/2 a tank so I filled up and added some fuel cleaner before the last canyon. My truck ran a little better up the last canyon. After droping off the trailer I drove up the canyon several miles to get a signal to post a thread here. After several more trips checking for replies and then towing back down the canyon I was down to 3/4 of a tank so I filled up again. The trip home went much better than the trip there but I am still not up to full power.

I am praying it was just crappy fuel or if my pick up screen was plugged up. I will run this tank almost empty to try to get rid of any fuel. I was thinking of dropping the tank and modifing the pick up system tube as in Guzzles website, then adding a helper pump and inline filter. This may be the best time for those mods. If I have any extra $ I am tempted to add a fuel pressure guage in my cab. I have had several friend with fuel pressure problems on their PSD's, now I will have to ask them more ? about there problems to see if they were similar.
 

·
Registered
Joined
·
82 Posts
Discussion Starter #9
I remember seeing 20lbs several times but I think it never held there consistantly. I would say it held at 18 lbs most of the time. I was letting on and off the gas trying to see what happened. It would get to 20-21 lbs but the turbo would surge too bad, sounded terrible so I had to back off. Then the surge would come back around 2100rpm so I had to stay above 2100 but below about 2900 or the turbo would start to scream. It was hard to keep it there because the motor would loose power and rpm would drop, then I would downshift but the rpm's would go too high and the turbo would scream. So I had to stay in second and do my best to keep in that rpm range. But that was tough even in second I was having a tough time holding those rpms. It was like I was dragging an anchor.
 

·
John Wood Nut Swinger
Joined
·
3,413 Posts
^^^^^ I am leaning towards the same assertation but he did say the EGT's were normal. That is what throws me off here.......HHHmmmm
 

·
Registered
Joined
·
2,412 Posts
Someone was telling me that a clogged filter (or lack of fuel pressure) reacts kinda like you are saying. I am no expert!
 

·
Registered
Joined
·
82 Posts
Discussion Starter #13
The EGT's were normal to maybe even a little low. I am going to order a fuel tank kit from ITP to eliminate the screen in the tank. It comes with a external replaceable filter. I am hoping that kit along with a new filter in the bowl and all new fuel I will be running ok again.

Now I just need a need to get rid of my turbo surge, that was horrible and not helping anything.
 

·
John Wood Nut Swinger
Joined
·
3,413 Posts

·
Registered
Joined
·
1,229 Posts
you said your egts seemed lower then normal and your boost seems low,i would say its a fuel issue.it seems like your truck should still have been able to pull 5k faster then 35mph with 18psi of boost.something is definitly wierd here,other then my spelling ofcourse.:thumb:
 

·
Premium Member
Joined
·
4,129 Posts
isnt that the exhaust side of the turbo?
lol your right! See what happens when you get in a hurry!

We had a guy come in today with the same issue. He pulled his fuel line and blew some low preasure air thru it. Fixed the problem for now. He'll be dropping the tank this weekend.
 

·
Premium Member
Joined
·
4,129 Posts
We have always done the exhaust housing and a whicked wheel. I dont know why you would buy the intake side AND a whicked wheel. Seems redundant.
 
1 - 20 of 23 Posts
Top