Ford Powerstroke Diesel Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1 (Edited)
2008 KRCC
I'm new to this forum so hopefully i'm doing this right.
Last week my truck started cranking for a long time before it would start. Then sometimes it will start as soon as the key is turned over. About a month ago I had the H&S mini maxx installed along with afe stage 2 intake and 5" down pipe back. I have drained the water separator and fuel filters were changed about 2 months ago along with oil and filter. Any help would be appreciated thanks
Also when running the truck runs like a champ
 

·
Registered
Joined
·
1,378 Posts
2008 KRCC
I'm new to this forum so hopefully i'm doing this right.
Last week my truck started cranking for a long time before it would start. Then sometimes it will start as soon as the key is turned over. About a month ago I had the H&S mini maxx installed along with afe stage 2 intake and 5" down pipe back. I have drained the water separator and fuel filters were changed about 2 months ago along with oil and filter. Any help would be appreciated thanks
Also when running the truck runs like a champ
How did the filters look when they were changed? I would probably try change them again. How about any codes popping up in the h&s?
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
The filters looked good when I changed them but that thought crossed my mind on changing them again and as for the codes I've tried to check the H&S monitor for them after each time it has done this but their weren't any codes popping up
 

·
Registered
Joined
·
4,329 Posts
How old are the batteries? Just an idea, I've heard the trucks doing weird things when batteries are low
 

·
Premium Member
Joined
·
8,819 Posts
Any codes?
 

·
Registered
Joined
·
2,107 Posts
My first guess would be batteries. Have you noticed a difference when the motor is hot vs cold, or the temp outside? It could be as simple as a loose battery cable.
 

·
Registered
Joined
·
769 Posts
Batteries can be tricky things... more so when there are two of them.

I'd go to a parts store and have them hook a load tester up to see how the batteries are functioning. They seem to be the culprit (plus they're easy to test).
 

·
Registered
Joined
·
12 Posts
Discussion Starter #8
Not sure on the batteries I just bought the truck about a year ago but I have yet to see any codes pop up when it happens I've also checked the screen on the monitor of the H&S
 

·
Registered
Joined
·
12 Posts
Discussion Starter #9
Doesn't seem to matter hot or cold. Would the batteries have to be pulled in order for them to do a load test ?
 

·
Registered
Joined
·
769 Posts
Doesn't seem to matter hot or cold. Would the batteries have to be pulled in order for them to do a load test ?
Not necessarily. It depends on where you go. Most autoparts store will do it on the truck for free. Worst case you'll have to disconnect your battery temporarily.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #11
I got my batteries checked tonight at Napa they checked out ok. I'm wondering if bad fuel could be the issue? I filled up tonight on fuel and was thinking of putting a fuel additive in the tank also and bought new fuel filters
 

·
Registered
Joined
·
769 Posts
I filled up tonight on fuel and was thinking of putting a fuel additive in the tank also and bought new fuel filters
New Motorcraft filters right? Don't use any other type of fuel or oil filter (except for Racor).

Are you letting the glowplug light go out?

I'd try another batch of fuel with additives first and see how that works.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #13
Im not sure on the brand of filters i know that the oil filter i put in was a wick oil filter when i changed the oil. At that point in time i hadn't heard of the filter issues that were going on but I don't know the brand of the fuel filters. I bought them from napa auto parts.

As for the glow plug light i wait on it to go out before i try and start the truck.
The fuel additive that i use is diesel kleen cetane boost
 

·
Registered
Joined
·
769 Posts
I seriously recommend you only use Motorcraft/Racor filters (fuel and oil) on this truck. Ford will deny warranties if you use anything else.

These are the only filters that are known (guaranteed) to fit the filter housings. When it comes to fuel filters, others are known to let water by or not filter at all or collapse.

I was never a huge stickler for filters before until I saw how many cases of 3rd party filters not working properly on the 6.4 there were and the damage these filters allowed to occur. Save your money elsewhere. Use regular oil. Get a cheaper air filter. Whatever... just don't save your money by cheaping out on these two filters.


Watch the video and read the warning. I'm sure just about every one on here will recommend only Motorcraft/Racor for fuel and oil filters.

Ford 6.4 Liter Turbo Diesel Truck Filters Page 2 - Diesel Filters,Additives,brake rotors, and brake pads for Chevy, Dodge and Ford Diesel Trucks
 

·
Registered
Joined
·
2,107 Posts
Could your starter be getting weak? I wouldnt think so but just throwing things out there if the new batch of fuel/additive dont work.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #16
Sorry its been awhile since i've been able to get on I have put a new tank of fuel in and have ran it through since my last post. I haven't had any more troubles with the long cranks since refueling. So crossing my fingers and hoping it was a bad batch of fuel.
Thank all of you for the help/suggestions
 
1 - 16 of 16 Posts
Top