Ford Powerstroke Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
265 Posts
Discussion Starter #1
ok so im not getting any signal to my gpr to even turn on........any ideas where to start
 

·
Powerstroke Junkie
Joined
·
8,308 Posts
Are you sure you are probing the right set of terminals? Are you sure you are probing the right relay? The GPR is the one to the rear? If all this is good trace the supply wires back until you find power and look for damage. Check your fuses and do you have a WTS light?

NCH
 

·
Registered
Joined
·
265 Posts
Discussion Starter #3
Yea I'm sure that I'm checking the correct terminal. Me and a ford tech of 22 years checked it and he told me couldn't give me a time on how long it would take or how much it would cost. Yea the wts light comes on and goes off just like it should
 

·
Registered
Joined
·
265 Posts
Discussion Starter #4

·
Registered
Joined
·
19 Posts
Are you refering to the orange wire on the rear small terminal that supplies a ground to the GPR from the PCM? If so I just went through this on mine and if the wire ohms out to the PCM plug at the firewall than it's in the PCM. I fried my PCM GPR contact that grounds out the relay, now I have to live with a push button to operate the GPR.
I tried a rebuilt PCM from auto computer exchange out of Florida and that was a waste of $300 The PCM they sent me had some serious issues, and like an idiot I broke the seal on it to try my DP chip and that voids their warenty. But my truck is not a guinnee pig for their poor rebuilds.
 
1 - 5 of 5 Posts
Top