Ford Powerstroke Diesel Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
4,295 Posts
Discussion Starter · #1 ·
Ok, where to start. I have another leak in the valley. It is black and looks oily but smells like fuel. I am low on oil but have a valve cover leak and I blame that. I get decent fuel milage about 15-17 in city but 15 on highway. It seems like at 2000 rpms or greater the truck looses alot of milage and I don't see why. But back to the main issue, I replaced the fuel filter housing and that stopped all the leaks a few months back, then I had a really bad fuel leak again so I replaced the fuel pump, with new crush washers and all, and that fixed the issue again. But now its back and worse than ever, I loose about 1 gal of oil every 1,500 miles. It smells really bad inside the truck but I think thats that valve cover too. I was thinking I might have done something wrong when I was installing these but that was about 6 and 9 months ago and never an issue since. I was kind of thinking HPOP or a bad hose somewhere but I am at a complete loss. :confused:
 

·
allergic to hot weather
Joined
·
1,208 Posts
there is an updated after market fuel filter top that fixed the leak on my ambulance the other day. it looked like the leak was elsewhere but that fixed it and we got it from napa.
hope this helps. good luck
 

·
Registered
Joined
·
4,295 Posts
Discussion Starter · #4 ·
Thanks for the post but since my fuel housing is fairly new I assume that the top is the new one too. Thanks tho
 

·
allergic to hot weather
Joined
·
1,208 Posts
did you buy the aftermarket?
pull the lid and look at the seat for the oring and see if it is beveled if it is its not the updated version. the new ones are flat
 

·
allergic to hot weather
Joined
·
1,208 Posts
if that is not the problem soak up the fuel and then start the truck for a very short time to see where the new fuel is located before it has time to pool in the valley. then you will be able to narrow down weather to look at the pump or filter housing
 

·
Registered
Joined
·
4,295 Posts
Discussion Starter · #8 ·
I know that the lid is not leaking because its really dry most of the problem is around the area between the fuel filter and the turbo. I keep thinking it has to be a hose, or it just still smells like fuel because how much leaked in there before. I kind of think its oil now because I checked underneath and theres oil all along the back of the block. It might be some turbo seals, but would those squirt alot and cause oil to get all over the valley.
 

·
allergic to hot weather
Joined
·
1,208 Posts
I know that the lid is not leaking because its really dry most of the problem is around the area between the fuel filter and the turbo. I keep thinking it has to be a hose, or it just still smells like fuel because how much leaked in there before. I kind of think its oil now because I checked underneath and theres oil all along the back of the block. It might be some turbo seals, but would those squirt alot and cause oil to get all over the valley.

yes turbo pedestal seals will do that.
 

·
Premium Member
Joined
·
8,298 Posts
1 - 11 of 11 Posts
Top