Ford Powerstroke Diesel Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
New to the forums
I have an issue with my 95 PSD at start up i have very heavy white smoke. Just had the injector O-rings replaced. the smoke is less now and goes away sooner but it is still a problem. Does anybody have an idea what could be causing this. The truck has 174,000 miles 5spd runs great after warm-up. Does not blow any smoke after the truck is warm. getting 15-17 mpg, so I’m not complaining there. it does not use oil?

Any help would be appreciated?
 

·
Banned
Joined
·
733 Posts
Did you replace all of your glowplugs when your injectors were serviced? On my 1996 six were dead, replaced them all and starts up at any temperature.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
No problem starting, just blows heavy white smoke for the first 3-5 mins
 

·
Desert Shield/Storm Vet
Joined
·
9,092 Posts
Do you have a tuner or chip?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
No tuner or chip the truck is basicly stock with only the listed mods
 

·
Desert Shield/Storm Vet
Joined
·
9,092 Posts
Did it only start after the injector install? If so then its possible you have a loose injector or two if not maybe its your glow plugs or relay.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
temps have been 35-55 does the same in the moring or after work prior to going home
same problem.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #9
problem was worse before the injector O-rings were replaced. the O-rings were in pieces
still smoke after but not as bad as before
 

·
Desert Shield/Storm Vet
Joined
·
9,092 Posts
Okay well you need to test out your glow plug relay and if that checks good ohm out the glow plugs to make sure they are working:thumb:
 

·
Registered
Joined
·
10 Posts
Discussion Starter #11
thanks I'll check that, could this also becaused by a sticking EBPV
 

·
Desert Shield/Storm Vet
Joined
·
9,092 Posts
No your getting the white smoke from unburnt fuel till the engine warms up:thumb:
 

·
Registered
Joined
·
136 Posts
my truck has always whited out the right side of my driveway in the cold and it sounds llike the exhaust is a vaccum cleaner and it runs a little rough till its warm then its fine 16-18 mpg 5spd w 4.10s
 
1 - 13 of 13 Posts
Top