Ford Powerstroke Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,674 Posts
Discussion Starter #1
I had the dealer install a reman HD 4R100 in my truck last week. All seems well with it, but I had one concern. Should they have installed an external filter? If so, where should it be because I'm not finding one.

Thanks, Bryce
 

·
Registered
Joined
·
1,674 Posts
Discussion Starter #3
They used to put a filter similar to a Magnefine in line in the cooler return along with the internal filter in the pan. Not sure when, but it looks like Ford has stopped doing this when they install a reman transmission.


Sent from my Autoguide iPhone app
 

·
Registered
Joined
·
6 Posts
I recently installed an external transmission filter kit on my 2000 SD Diesel 4X4 with an automatic transmission. Yesterday, I dropped the pan and changed the factory filter in the transmission. The fluid looked like new, there was no staining on the pan. There were some typical tiny metal debris attached to the magnets, but nothing else. The Fluid and factory filter had 33K on it. I towed a car trailer and had the truck loaded to the max for 6K during this event. 10K ago, I installed the remote spin on filter purchased from Dieselsite.com. the inside of my transmission is spotless.
 

·
Registered
Joined
·
598 Posts
I had the dealer install a reman HD 4R100 in my truck last week. All seems well with it, but I had one concern. Should they have installed an external filter? If so, where should it be because I'm not finding one.

Thanks, Bryce
having transmission issues and was thinking of going with the ford hd4r100. how do you like yours?
 

·
Registered
Joined
·
1,674 Posts
Discussion Starter #6
having transmission issues and was thinking of going with the ford hd4r100. how do you like yours?
No issues other than the dealer was an idiot. I had to inform them that there is a HD 4R100 and get the part number.

The transmission is great and they got me in and out in 2 days. There was a transmission already local to Atlanta, so in one morning out the next afternoon.

Shifts fine.

My only I've noticed is that some say it should run 50-60 deg over ambient... mine runs 70-75 over, some say 70-80 is normal temp. I've never seen it over 140 even when temps are higher than 65, so I'm not too concerned.

Towed with it once so far. did fine. about a 7500lbs travel trailer.
 
1 - 6 of 6 Posts
Top