Ford Powerstroke Diesel Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi, new member here. Just bought an 04 F350 6.0 Lariat.

Hazard lights don’t work (light on button does work that displays “on“ when pressed However no flashing. My turn signals do work.
Also, cigar lighter and power point has no power. checked fuses and replaced but still no power.

also noticed that I have extra connections. Are these just part of factory wiring harness? Can’t find any good information on this.


any help would be greatly appreciated. Thanks.
 

Attachments

·
Super Moderator
Joined
·
19,759 Posts
You may have to do some wire tracing - no telling if the PO did some stuff under there.

The gray connector looks like the plug for adding a Trailer Brake controller into the trucks wiring. Not sure about the others.
 

·
Registered
Joined
·
1,455 Posts
Those connections are part of the factory harness, but for stuff you don't have.
1) You have a bad fuse.
Fuse 4 -power point (instrument cluster) 20a
Fuse 12 -cigar lighter/obd port 20a
Fuse 18 -boo lamps (brakes and flashers) 20a
Fuse 34 - boo switch 10a

These are from an 06, but, I believe they're mostly the same. Replace all these fuses, no matter what they look like, it's cheap maintenance.

2) The instrument cluster is going bad, the instrument cluster controls a lot of stuff. It can be sent off for repair.

3) the whole cjb could be bad. It's not unheard of and I believe fairly common on the 03-04 trucks (they're old now). If this is the case, you'd replace it with a new one, no way to repair it. You can pull it easy enough and inspect the back side for rust or corrosion. Make sure the batteries are disconnected as there's power to the box 100% of the time and in different locations (feeds).

Sent from my Redmi Note 9 Pro using Tapatalk
 
1 - 3 of 3 Posts
Top