Ford Powerstroke Diesel Forum banner

1 - 20 of 50 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Wanted to try out a different transmission tune on a 2010 6.4 batteries were recently charged, went to load tune and got stuck so I unplugged tuner and tried again in recovery mode now it loads the stock engine and trans tune, but gets stuck on turn engine to run, truck will not start any help is appreciated. Battery charger has been used batteries show to be at 100% charge.
 

·
Registered
Joined
·
481 Posts
i yanked mine off one day doing a trans check and wqas in a hurry and well i sat there in that parking lot for two hours trying to get it to reload and start. my best advice is unhook the batteries to let the truck itself reset and then reload the stock tunes and gpo from there, it can be a pain and i am sure there might be a better way but i hope that helps
 

·
Registered
Joined
·
481 Posts
the only other option would be having it flashed from a dealer and then reload your tunes but it means towing and havine a shop charge reflash fee for the truck
 

·
Registered
Joined
·
28 Posts
Discussion Starter #4
I disconnected the batteries for about 2 hours and charged them again, it still gets stuck on turn key to run, as soon as I turn the key to run with or without tuner its throwing abs and some other codes hopefully I can troubleshoot this somehow to narrow it down, when I try to clear dtcs with tuner it takes a while to actually read the codes I also had to unplug tuner and retry not sure if that's related to anything. This xrt pro also has an 8 gig memory card I heard that can cause issues, that your only suppose to have a 2gig the truck's been tuned 4 or so times by me with little issues this has happened before but always fixed itself in a few minutes.any help is appreciated
 

·
Registered
Joined
·
481 Posts
i know your frustrastion it is enough to pull your hair out at time. i had to learn the hard way with my tuner but it has made me more at ease with it when it goes goofy. it could just be struggling with a brain fart ion the programing sounds like
 

·
Registered
Joined
·
28 Posts
Discussion Starter #6
I've got the batteries unplugged, is there any way I can troubleshoot the pcm and make sure it's not the problem?
 

·
Registered
Joined
·
481 Posts
i dont know other then having a shop or i think there are scaners you can get to check. i wasted 400 bucks at ford just to figure it out myself when in the end mine was just needing it reloaded but i did have a ttransmission issue shortly after which i think was the main thing causing it to shut down like it did, but that was a whole different deal
 

·
Registered
Joined
·
28 Posts
Discussion Starter #8
When does the memory reset on the truck when the batteries are unplugged? Thought it was 30 minutes, I'm gonna leave it unplugged until 6 or so I went ahead and removed sd card cleaned the tuner with compressed air hopefully it will work. I think it's all the codes that popping up normally they come on periodically and clear off on there own while the tuners plugged in.
 

·
Registered
Joined
·
481 Posts
it should be good to go after waiting that long crossing my fingers for you. remmber it will have to relearn the shifting and all that fun stuff
 

·
Registered
Joined
·
28 Posts
Discussion Starter #10
It says in the instructions that it's highly recommended to disconnect the sensors that were connected to the dp.f I kept mine connected a taped them up out of the way don't know how it would affect it now after tuning so many times. but it seems like I've always had this problem where it loads the engine and trans files then gets stuck on turn key to run position, but it's usually disconnect and it works on the 2nd or third attempt wonder if it's something electrical on the truck itself? Anybody else had this particular problem?
 

·
Registered
Joined
·
28 Posts
Discussion Starter #12
I went ahead and tried it early still the same thing, I unplugged all the dp.f sensors before i tried it, it still has abs module fault, trailer control module fault and tpms fault as soon as I tun the key to run, I hooked up my battery charger and the battery had run down to 67% was holding 12.5 what's the recommended number to tune these trucks?
 

·
Registered
Joined
·
481 Posts
a fault like that would cause a no start tied into the saftey features in the trucks brain. i would look into new batteries i have never had it drain my batteries using h&s tuner.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #14
One battery is a 2019 the other is less than 3 months old, I might try to get another battery it seems like its always the battery every time I tune this truck or at least that's what's seems to have fixed it before, I thought the same thing considering mini maxx tuners stay plugged in, could it be a the tuner itself?
 

·
Registered
Joined
·
481 Posts
maybe it is hard to say , just be a fluke in the batterys but i would keep a heads up on maybe somthing causing a drain. i have never had an issue with my tuner draining them
 

·
Registered
Joined
·
28 Posts
Discussion Starter #16
Ya I had the headlights off not on auto, had the gauge cluster cargo light turned all the way down, nothing was plugged in the outlets inside besides the tuner, maybe the led headlights they weren't on though that's the only thing i can think of. That's the only thing aftermarket besides tune, I went ahead and unplugged the battery gonna leave it over night.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #18
Is there anybody I can call that's worked or works for h&s to see if they can walk me through it or narrow the problem down?
 
1 - 20 of 50 Posts
Top