Ford Powerstroke Diesel Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 2000 7.3 and my glow plug relay does not shut off. I can unhook the small wire to the relay and my voltage goes up to 13.5 but when I leave it on it stays down below 12 volts constantly
 

·
Registered
Joined
·
707 Posts
So replace it?


Sent from my SM-G988U using Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
So replace it?


Sent from my SM-G988U using Tapatalk
The relay is not the problem, the other small wire I guess coming from the computer never opens, it keeps the relay circuit closed, I put my ohms meter on that wire and after a minute the resistance go up but not enough to open up the circuit. So what started all this was I thought I had a bad alternator because the voltage never got up above 12 when it was running, replace the alternator did the same thing did some investigating and realized the glow plug relay was never shutting off.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
The relay is not the problem, the other small wire I guess coming from the computer never opens, it keeps the relay circuit closed, I put my ohms meter on that wire and after a minute the resistance go up but not enough to open up the circuit. So what started all this was I thought I had a bad alternator because the voltage never got up above 12 when it was running, replace the alternator did the same thing did some investigating and realized the glow plug relay was never shutting off.
[and yes I did replaced the glow plug relay with a good one/QUOTE]
 

·
Registered
Joined
·
18 Posts
While chasing down your issue, you could maybe run a switched ground through the firewall to that terminal so you can control it regardless of PCM...
 

·
Registered
Joined
·
18 Posts
Can you probe from PCM plug for resistance to chassis ground? That way you can isolate pcm as a non-issue and run a new wire...
 

·
Registered
Joined
·
8,969 Posts
How long are you letting it sit before testing? If it only stays on for a couple of minutes depending how cold it is that's normal. It doesn't shut off right away etc.
 

·
Registered
Joined
·
707 Posts
The relay is not the problem, the other small wire I guess coming from the computer never opens, it keeps the relay circuit closed, I put my ohms meter on that wire and after a minute the resistance go up but not enough to open up the circuit. So what started all this was I thought I had a bad alternator because the voltage never got up above 12 when it was running, replace the alternator did the same thing did some investigating and realized the glow plug relay was never shutting off.
What do you mean "never opens?" The pcm supplies ground to energize the relay. Receives 12+ when off.

Sent from my SM-G988U using Tapatalk
 

·
Premium Member
Joined
·
8,475 Posts
What do you mean "never opens?" The pcm supplies ground to energize the relay. Receives 12+ when off.
Just to be clear...

The coil inside the relay connects the two small posts. The Key supplies 12v to One side, the coil passes it to the other (to properly test the wiring and it's function, you have to Remove those Two Sm wires from the relay). You'll find the 12v source wire and the other one is the Path-to-Ground wire that the PCM uses for activation. When cold, and Only when cold despite the WTS being On, you can measure current flowing with a meter to the PCM's wire (put 12v in the meters Red lead).
 
1 - 9 of 9 Posts
Top