Ford Powerstroke Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
Alrighty guys.... I'm at a bit of a loss on this one...


A buddy has a Van,7.3 Non Turbo.
VERY hard start.
5 out of 8 glow plugs bad.

Replaced them all, still a hard start.
Replaced the controller.
Still a hard start.
So... checking the glow plugs they pulse on and off rather quickly. They don't just turn on and stay on while the light is on.

The truck is still a hard start, although not as hard as it was.
Any ideas guys?
 

·
Registered
Joined
·
386 Posts
for the relay to work properly it must have 12v of current pulled from the glow plugs also the wire harness are easily burned up pull all 8 g/p wires off and take a volt meter to one at a time and see if your getting 12v at each turn key on and you should get 12v
 

·
Registered
Joined
·
33 Posts
Discussion Starter #3
All of the glow plug wires could make a test light come on brightly. I'll have to check the harness more closely. Thanks!
 

·
Registered
Joined
·
521 Posts
Is the starter still good. Alot of cranking can kill them quickly.
I have had the same problem with my truck and spent alot of time chasing ghosts.
Same goes for the batteries.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #5
This seems to be more of an issue with the plugs being turned on/off/on/off/on/off repeadily
 

·
Super Moderator
Joined
·
31,733 Posts
Josh shoot Scuffy828 a PM he's a ford diesel tech here. he might be able to help you out
 

·
Premium Member
Joined
·
9,390 Posts
the on/off on/off you are referring to is normal for that style glow plug module they will do that when they sense that the glow plugs are hot enough, that is normal , alot of cold start problems with 7.3 idi , are related to low base fuel pressure at start up, or worn out injection pump
 
1 - 7 of 7 Posts
Top