Ford Powerstroke Diesel Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Truck is a 06 F350 6.0 xlt. Driving yesterday tack and speedo went to 0 and check engine light came on with a buzzer, then the gauges came right back on like normal. Checked codes and got u1900. Anybody had something like this before? Thanks for your time. George
 

·
Registered
Joined
·
634 Posts
All I can find about that code is this....

Various Electronic and Driveability Symptoms and Codes:
2005 F-Super Duty trucks built before 5-11-05 may exhibit various electronic-related symptoms due to loose/miss-installed fuses in the engine compartment fuse box. These symptoms may be intermittent. The fuses should be inspected to verify they are installed into the terminals in the fuse box and not along side the terminals.
Fuses--Symptoms
#9, 20 amp: Trailer turn signals inoperative
#10, 10 amp: Check Engine Light; Codes P1633, P0446
#11, 10 amp: Speedo bounce, ABS light, Cruise control inop; Codes U1900, U2023, P0500-P0503
#12, 2 amp: Cruise control inop, TBC Fault displayed, chime; Code C2803
#13, 15 amp: Day time running lamps inop
#15, 15 amp: Crank/no start, bucking, stall; Codes P2614, P2617, P1378
#17, 10 amp: A/C inop or not cooling
#18, 10 amp: Crank/no start, bucking, stall; P2614, P2617, P1378, P0611
#20, 10 amp: Trailer back up lamp inop
TSB 05-11-14

I would check fuse 11 in the engine compartment and make sure it is seated properly.

Other than that I have no idea. Hopefully someone else will come along and give some input.
 
1 - 3 of 3 Posts
Top