Ford Powerstroke Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi, first time poster with a problem.

Vehicle: 2002 Excursion, 4x4, 7.3L. 117,000 miles.

About 4 months ago, I started noticing a small diesel leak in the center of the engine, but couldn't trace the origin and wasn't too concerned about it. Thought it might have been from the fuel filter gasket leaking and was due to change it. Engine started easily and ran fine with no significant fuel odor while running.

About 3 months ago, I replaced the fuel filter with a Napa (Wix) and didn't notice any leak at first, but started noticing a small leak again after about a week.

About a month ago, it started fine and went about a mile and started running rough stalled out. I suspected water in the fuel and drained the fuel filter housing. Engine ran fine. This happened a few times, always in the morning, and when I let out some fuel in the housing, it ran fine afterwards.

A couple of days ago, I noticed that the transmission was slow to shift to the higher gears. I had to left off the gas a little for it to shift. ATF level is fine.

Yesterday, the service engine light (the silhouette of an engine) came on. Engine runs okay, not as smooth as it was.

Any ideas? Water in tank? ICP? When I let out fuel out of fuel filter housing, I don't notice any water. Is the transmission coincidental or could it be related to the diesel?

FWIW, I was a wrench 30 years ago as a 20yo but never had much experience with diesels.
 

·
<-Day Of Fail now SOLD
Joined
·
3,393 Posts
Where you located maybe one of the local boys can stop by and help out.

Best of luck, heres a bump
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Fixed it. Done. Saved a ton of $$$ by not having to take it to the dealer as the wife wanted to.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
It was the ICP sensor and the pigtail harness. Replaced both for $233. If you have any specific questions, pm me.
 
1 - 5 of 5 Posts
Top