Ford Powerstroke Diesel Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter #1
replaced my fuel filter the other day along with changing my oil done it about 3 or 4 times before and never had a problem use the aftermarket filter and cap since thats what it had when i bought it... i drained the bowl put in the new filter put fresh fuel on the new o ring put the beveled edge up like the directions said and it leaks around the cap like hell...i thought maybe i over tightened it so i got another o ring and did it again and still the same thing i have herd some people say to put the beveled edge down but the directions clearly say to put it up..are these filters just crap and should i go to the oem cap and filter??? am i doing something wrong... i finally got it to seal after about 30 mins of messing with it but then it started to leak the next day :banghead:
 

·
Registered
Joined
·
84 Posts
Discussion Starter #2
anybody??:help1:
 

·
Registered
Joined
·
154 Posts
Is it the factory lid?
Or is it the filter attached to a new lid all in one unit?



Sent from my iPhone using Autoguide
 

·
Registered
Joined
·
84 Posts
Discussion Starter #4
all in one unit thats what was on it when i got it
 

·
Registered
Joined
·
154 Posts
I personally like the factory cap, go to international and buy their filter.

Make sure the gasket doesn't twist or "fall in" when your tightening cap down. Make sure the cap goes in level and not cross threaded, if goes in cross threaded you might think you got it right when stops but nope.

Bevelled side goes up, flat side down for gasket. Put cap on, spin it in the off direction till threads are lined up and than start to instal, use flash light and watch gasket. Should go perfect for u.

Is that how you did it?


Sent from my iPhone using Autoguide
 

·
Registered
Joined
·
84 Posts
Discussion Starter #6
yep pretty much ive looked for cracks,defects in the gasket and nothing i ordered the factory lid and filter so that should be here soon hopefully that solves the issue
 

·
Registered
Joined
·
154 Posts
Over tightening will just break the plastic cap and will come loose, don't think that's your problem. Make sure you have a flat seal all the way around the lid. Sounds like problem with cap.

Jus to make sure look at top of your filter bowl for cracks just incase, I've never seen it but don't hurt to inspect it all.

Good luck, hope new cap is it!


Sent from my iPhone using Autoguide
 

·
Registered
Joined
·
889 Posts
Is the lid itself flat?
I had problems with a WIX filter/lid unit a while back that looked like it got sandwiched during shipping. Had about 1/8" of run-out (unofficial measurement taken with a table and a dial indicator).
 

·
Registered
Joined
·
84 Posts
Discussion Starter #9
got a factory lid and filter and no more leak...looking at the 2 lids i had since i bought another filter of the same kind thinking it would fix it (duralast filter) they are actually slightly warped ? not much very hard to notice if not in the light but that was it
 
1 - 9 of 9 Posts
Top