Ford Powerstroke Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #1 (Edited)
My fuel gauge seems to be pegged full despite having less than half of a tank (stock tank). I have read that the sender can go bad or that the writing itself can go bad as well. Where are some common problem areas along the truck having to do with fuel readout (i.e: chaffing spots)? Thank you!
 

·
Registered
Joined
·
3,551 Posts
Unless you just installed a new tank, might not be what you're looking for, but for a Titan 51 gallon tank, that is perfectly normal. I fill up, drive about 200 miles, and the needle starts to move. During that time, I get some type of fuel sensor code with a CEL. I usually get this code, but sometimes not. Perhaps, if you get this code, may indicate something in the tank, but not getting the code does not mean the tank is working. I think my tank is a little deeper than normal and the float is stuck at the top for too long, tripping the code.
 

·
Premium Member
Joined
·
2,709 Posts
Two ways to get to the sender -- Drop the tank or Tilt the bed

You can loosen the passenger side bolts, and remove the driver side bolts, than block up the bed
--or-- drain and remove the tank -- likely needs cleaning anyways
Once the sender is out -- reconnect the harness and stroke the sender both ways while observing the gauge
the little arm that is hooked to the float arm, wears out or breaks -- that is what rides on the resistive materal
Seen a mod using a Crown Vic sender, instead of the more expensive F series one -- if your "handy" may want to look for this

where the harness runs from the tank to the frame can get pinched, so look there first
 

·
Registered
Joined
·
8 Posts
I had the same problem in my 07 F250. The algae in fuel sitting can cause your sensor to read wrong and after a few fill ups plus fuel system cleaner my works right.

Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
64 Posts
Discussion Starter #6
I had the same problem in my 07 F250. The algae in fuel sitting can cause your sensor to read wrong and after a few fill ups plus fuel system cleaner my works right.

Sent from my SM-N960U using Tapatalk
I'm going to give this a shot. I bought some PowerService Clear Diesel tank and fuel system cleaner. I'm hoping that it's just gunk that is causing my issue. I'll let you all know if my tragedy improves... Thanks!
 

·
Premium Member
Joined
·
661 Posts
Give the fuel tank a little tap with a mallet under the sender and it may free it up. Has worked for me a couple of time when the fuel tank was full but the gauge was reading empty.
BTL
 
1 - 7 of 7 Posts
Top