Ford Powerstroke Diesel Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
Ok so I had a cracked board in my fuse box. I replaced it and now my radio and windows do not work. I checked fuses and relays relating to both those including the delay acc fuse and relay. I'm stuck and I have no clue what to do. I tried searching but can't find anything.
 

·
Administrator
Joined
·
33,365 Posts
so they worked with the cracked board but not wit the replacement?

i was thinking retained power but you checked that
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #3 ·
so they worked with the cracked board but not wit the replacement?

i was thinking retained power but you checked that
Correct. The only thing effected by cracked board was starting truck. I could have it turned to run and everything worked. Once the fuse box was switched out it's like the relay isn't getting power. I don't know where my test light is but I can't hear/feel relay actuating. Somebody mentioned the gem but I thought those were for the 7.3 not the 6.0. Or am I mistaken? Anything at all would help me.
 

·
Administrator
Joined
·
33,365 Posts
no Gem your correct the cluster and separate modules take it's place

an since your problem followed the new board i guess you better find your test light

??
 

·
Administrator
Joined
·
33,365 Posts
i have not messed with the retained power but if it's like most relays it interrupts the power between two leads so you may still hear the coil click but it may not have any power to interrupt
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #8 ·
eBay board and it was model specific matched code 100% I did already pull it and reinstall. It's rather a simple install. I'm just getting a bit frustrated. Seems elec issues are my downfall.
 

·
Administrator
Joined
·
33,365 Posts
the board has me worried and if i didn't have a sleeping chihuahua on my leg I would try and look in the wiring book to see where the power feed to the retained power relay comes from but that's my guess

did u compare the boards or is it to complex to do a side by side ?
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #10 ·
Unfortunately you can't really see the board unless you look through one of the relay proNg slots. Everything is one piece. I looked for a diagram but couldn't find anything relating to that.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #14 ·
I'm a little confused on diagram. I don't know much about what I'm looking for or at. There are a few acronyms I'm not sure of.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #18 ·
Ok so those fuses and relays are all testing good. And just to be safe I switched fuses out and moved around relays. Still not working. I don't understand this.
 
1 - 20 of 22 Posts
Top