Ford Powerstroke Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
164 Posts
Discussion Starter #1 (Edited)
I have an '03 that has developed a rattle that I thought was ball joints. I tried jacking and pulling top and bottom of both tires, no movement. I then tried prying up on the tire while jacked, no movement. Nothing appears loose, all sway bar bushings look intacked, track bar is solid. I'm not saying it's not any of these items but I don't know how to check them properly. Also can the leaf springs make noise? I did notice that the front half of the leaf ahead of the axel has no seperator/insulator and if hit with a medium dead blow it will rattle against the upper leaf. Any advice is welcomed. I already have the Powerstrokeshop ball joint kit on hand but dont want to replace them yet if that's not my rattle (I'll be paying someone to R&R them).
Also, this rattle is not cyclical or turning related, speed is not related. It sounds (to me) like ball joints rattling in their sockets. I also think it sounds like a shot upper sway bar link. It also makes me imagine leaf spring slap. These are the what I imagine while I'm driving down the road because it eminates through the floorboardsjust figured I'd get somekind of movement with bad ball joints. Hopefully these descriptions help. Thanks

snoboy
 

·
Registered
Joined
·
105 Posts
I have the same problem, I did the ball joints, the shocks, and the U-joints, still have the rattle. I only hear it when hitting bumps. Can anyone help on this???
 

·
Registered
Joined
·
1,933 Posts
have you checked all your lines under your truck there are alot that run right under you the main ones are your gas lines ...you can check make sure all lines are tight and not loose and bouncing around ............i had a rattle on mine and found out it was the front grill ...the bottom clips didnt hold it in very tight .....but good luck
 

·
Registered
Joined
·
435 Posts
I have the same problem, I did the ball joints, the shocks, and the U-joints, still have the rattle. I only hear it when hitting bumps. Can anyone help on this???
Check your lower shock bolts, mine were under sized, wore to a point where one broke. :doh: Replaced with M12, 1.75X80mm, Nylock nuts and lock washers. It helped mine most of my noise went away. Still have a ball joint issue fixing soon.

Pull your bolts out look for wear, remove the lower part of shock and insert the bolt in the shock check for movement, insert the bolt in the mount and check for movement.

Hope this helps. :thumb:
 

·
Premium Member
Joined
·
5,441 Posts
I have the same problem, I did the ball joints, the shocks, and the U-joints, still have the rattle. I only hear it when hitting bumps. Can anyone help on this???
I would bet it's your sway bar end links. Their notorious for going bad. Get the whole link i have heard that it's a real PITA to change just the bushings. Their not real expensive either. :thumb:
 

·
Registered
Joined
·
435 Posts
I'll second the PITA on the links, I did it and it took a BFH and several big hits to break them loose. A big press would have made it so much easier.
 
1 - 6 of 6 Posts
Top